Find the answer to your Linux question:
Results 1 to 5 of 5
In Xubuntu v. 8.04.1 I'm getting errors like: "Could not look up internet address for <hostname>. This will prevent Xfce from operating correctly It may be possible to correct the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2008
    Posts
    3

    /etc/hosts file not there


    In Xubuntu v. 8.04.1

    I'm getting errors like:

    "Could not look up internet address for <hostname>. This will prevent Xfce from operating correctly It may be possible to correct the problem by adding <hostname> to the file/etc/hosts on your system." at start up after log-in,

    "unable to resolve host <name>" in the terminal,

    "Unable to find host <name>" in the terminal,

    "/etc/hosts permission denied" in the terminal,

    and I can't find a hosts folder in file/etc/.

    I am unable to create a file in the GUI file manager (the "new folder" command is grayed out) and unable to login-in in the terminal to create a file.

    I found all of this in my attempts to connect the computer to my network. It does go online with Firefox with no trouble.

    My searches have found nothing about this problem.

    I'm using a old Packad Bell with a Pentium MMX processor and 256 MB of memory with a 10-100 ethernet card connected to a Linksys WRT54G router which is connected to DSL. I am also having trouble with Xubuntu on a Compaq Presario 700 laptop with an AMD Athlon and 384 MB memory.

    Is there something missing in the OP system? I downloaded the OP system and burned an image disc of it before installing it on the Packard Bell and running it as a live CD on the laptop.

    Help! Please!

  2. #2
    Linux Engineer b2bwild's Avatar
    Join Date
    Jul 2008
    Location
    Behind You!
    Posts
    1,108
    It will be gryed out, if you dont have permissions
    1. Are you login as root?
    2. /etc/hosts isnt own by any package, so you can create it by yourself.
    3. You have to create empty file not folder.
    4. If you are having hostname resolution problem.. put your nameserver enty in /etc/resolv.conf
    like
    vim /etc/resolv.conf
    add
    nameserver <DNS IP provided by ISP>
    Never make any misteaks.

    Read my Blog at --> Penguin Inside Subscribe Feed

  3. #3
    Just Joined!
    Join Date
    Aug 2008
    Location
    Columbia, TN
    Posts
    14

    /etc/hosts not there

    You may have a file named /etc/HOSTNAME that contains your hostname or linux.system instead of /etc/hosts.

    The previous post was right though, you can create your own /etc/host file, not folder. you should have one in /etc/defaults folder or /etc/templates to use as a model.

    After you make the /etc/hosts file, you can put in the hostname you want and use the ipaddr assigned by your ISP provider's DCHP server. Although that ipaddr will change, it still allows the host to be resolved from the /etc/hosts file after removing or renaming the /etc/HOSTNAME file.

    You may get the assigned ipaddr by typing /sbin/ifconfig -a . You should get a block with stats about eth0.

    I have done this hostname change and it works as far as the hostname or uname command is concerned and my KDE login graphic. Can't say if it will help other machines on your network see the machine you are modifing. This change did not prevent me from connecting to the net.

    I hope this helps some.
    chill92

  4. #4
    Just Joined!
    Join Date
    Aug 2008
    Posts
    3
    OK, Thanks to both of you. I will give that a try in the next day or two when I have a chance to work on it.- Bart

  5. #5
    Just Joined!
    Join Date
    Aug 2008
    Posts
    3
    My son, who is Linux savvy, and I applied the changes to the host file and that resolved some errors. Several other things were done as well, but everything is still not right.

    We tried to turn Ubuntu into Xubuntu by removing Gnome and adding Xfce on a dual boot system. Bad idea. When Gnome is removed it takes all the config file settings and dependencies with it, but putting Xfce in doesn't replace them. Finding them all and restoring them is a major hassle and there seems to always be something left that is missing or configured wrong or not configured at all. It would be better to find a way to clean out the old operating system and partition and install fresh the new system. Now my son is contemplating formatting the partition or hard drive and doing a fresh install.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •