After a lot of headaches getting a linux distro to willingly install and function properly, I've now been stumped by identd. First, I left the default alone and was going to use the default identd. I attempted to do 'telnet localhost auth' and it gave me the normal prompt. Assuming everything was well, I tried to connect to efnet in *****X, but there was no ident response. I checked my router's firewall settings, doublechecked port 113 was forwarded to this box, and tried to telnet to port 113 from a remote machine (a dedicated server on the other side of the world). From that box, I could still telnet into port 113. I checked my /var/log/messages and got this:

in.identd[2032]: reply to 64.156.25.83: 61969 , 6667 : ERROR: UNKNOWN-ERROR

Assuming it was just a weird glitch in the default identd, I disabled it in inetd.conf, downloaded oidentd, installed it the same as it is on my dedicated server, checked that port 113 was allowing connections still, and tried again to get on efnet. Still no ident response.

oidentd[2308]: [irc.prison.net] 61983 , 6667 : ERROR : NO-USER

Not looking good for me! I have not configured any form of a software firewall in linux, so there should be nothing blocking identd from functioning properly. Or am I missing something.

Setup:
D-Link DI-614+ Router
Intel e100 nic
All network setup was done by Slackware 10's installer. All I did was enter a bogus hostname and domain name (it said it didn't matter )