Find the answer to your Linux question:
Results 1 to 3 of 3
Trying to open access share in a Controlled network environment (my house, all wired computers) without having to provide a user name or password. Everytime I try to access the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2008
    Posts
    7

    [SOLVED] more Samba


    Trying to open access share in a Controlled network environment (my house, all wired computers) without having to provide a user name or password.

    Everytime I try to access the Samba share from windows it requires a a log in. Not only that but it provides "sharename/GUEST" as the name and greys it out and only allows a password to be typed in.. needless to say, no password I provide fits the bill.
    smb.conf follows

    [global]
    netbios name = Sharename
    workgroup = WKGNAME
    security = share
    [Musicz]
    path = /folderpath
    available = yes
    browseable = yes
    read only = no
    guest ok = yes
    public = yes
    writeable = yes
    guest only = yes
    force user = nobody
    force group = nogroup


    I have tried it with and w/o the force user/group tags and still receive a log in box. neither apparmor or iptables are running on the linux box. I have chmod 777 to the share folder as well with same results.. anything else I'm missing?

  2. #2
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,672
    This link should help you out.

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  3. #3
    Just Joined!
    Join Date
    Sep 2008
    Posts
    7
    Thanks for the link. Followed it to the tee. Still no go, same problem occuring.

    I've checked smbclient -L servername.

    It's all running correctly. And I can just hit enter when it asks for a pass, but still can't get windows to connect.

    EDIT SOLVED*
    Kind of silly, I had the path name going to a symlink... Windows or Samba didn't like that, I redirected to the actual folder and everything is just peachy.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •