Find the answer to your Linux question:
Results 1 to 3 of 3
I have two interfaces on my ubuntu 8.04 machine, eth0 and eth1. eth0 is for internet(working) and eth1 uses dhcp with a static ip(not working) for my other computers on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2008
    Posts
    84

    Setting up a home network problem


    I have two interfaces on my ubuntu 8.04 machine, eth0 and eth1. eth0 is for internet(working) and eth1 uses dhcp with a static ip(not working) for my other computers on the network.

    My windows machine can't ping domain names or ips when connected to eth1. It acquires an ip address from my dhcp3 server and can ping the static ip, but nothing on the internet. I also tried disabling ufw.

    -----------------------
    /etc/network/interfaces

    auto lo
    iface lo inet loopback

    iface eth0 inet dhcp

    iface eth1 inet static
    address 192.168.0.1
    netmask 255.255.255.0
    gateway 192.168.0.1

    auto eth0
    auto eth1
    -----------------------
    /etc/dhcp3/dhcpd.conf

    default-lease-time 600;
    max-lease-time 7200;
    option subnet-mask 255.255.255.0;
    option broadcast-address 192.168.0.255;
    option routers 192.168.0.1;
    option domain-name-servers 64.71.255.198;
    option domain-name "shwick.mydomain";

    subnet 192.168.0.0 netmask 255.255.255.0 {
    range 192.168.0.2 192.168.0.100;
    }
    -----------------------
    /etc/default/dhcp3-server

    INTERFACES="eth1"
    -----------------------
    /etc/resolv.conf

    search phub.net.cable.rogers.com
    nameserver 64.71.255.198


    I'm thinking this has something to do with the gateway. When I enter a gateway in interfaces for eth1, interface eth0 can't connect/ping the internet.

    I read through the ubuntu server guide but I'm really confused right now, any help is welcome.

  2. #2
    Just Joined! garyalex's Avatar
    Join Date
    Jun 2008
    Location
    Johannesburg, South Africa
    Posts
    16
    Have you enabled IP Forwarding?

    /etc/sysctl.conf
    Code:
    net.ipv4.ip_forward = 1
    You would also need to masquerade the internal network.

    If for example your internal network is 192.168.0.0/24 the below would apply:
    Code:
    iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -j MASQUERADE

  3. #3
    Just Joined!
    Join Date
    Jun 2008
    Posts
    84
    Sorry for the long time before reply.

    The problem was that I didn't have port forwarding enabled. I disabled ufw because it was going to cause problems moving forward with other services. I used this as a guide to enable port forwarding with iptables: https://help.ubuntu.com/community/In...nectionSharing

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •