Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
HEllo I'm desperate for help on making the device to work I have Arch Linux Kernel v 2.6.26 On install hw detection added two modules for my network card: 8139cp ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2008
    Posts
    5

    Thumbs down Realtek 8139/810x PCI Network Card Issue


    HEllo

    I'm desperate for help on making the device to work
    I have Arch Linux Kernel v 2.6.26

    On install hw detection added two modules for my network card: 8139cp & 8139too
    However none of these worked - either together or separate.
    I have dualboot Vista & Arch, and in Vista device works fine by DHCP, but in Arch refuses either by DHCP or by entering static data

    Pls help me

    when trying to ping like www.google.com - reports: unknown host

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Hi Sader,
    Welcome to Linuxforums. Can you give us the output of these commands please.
    Code:
    lspci | grep net
    Code:
    ifconfig
    Code:
    cat /etc/resolv.conf
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Not sure it will work, but you could try adding the following to the end of the kernel line in your menu.lst file to see if that helps:

    Code:
    pnpbios=off pnpacpi=off
    oz

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2008
    Posts
    5
    Thanks for quick reply

    Everything is attached here in

    ifconfig.txt

    lspci.txt

    lsmod.txt

    rc_conf.txt

    resolv_conf.txt

  6. #5
    Just Joined!
    Join Date
    Oct 2008
    Posts
    5
    Quote Originally Posted by ozar View Post
    Not sure it will work, but you could try adding the following to the end of the kernel line in your menu.lst file to see if that helps:

    Code:
    pnpbios=off pnpacpi=off
    this did not help

  7. #6
    Just Joined!
    Join Date
    Oct 2008
    Posts
    5
    Somebody......Anybody.....

  8. #7
    Just Joined!
    Join Date
    Jun 2006
    Posts
    8
    No answer I'm afraid but it looks like I have the same problem.

    Have you tried Knoppix on your machine. I have and it woirks under knoppix. This doesn't solve the problem of course but it does help in a way.
    http://www.linuxforums.org/forum/man...onnection.html

  9. #8
    Just Joined!
    Join Date
    Oct 2008
    Posts
    5
    well, I do have eth0 with 8139too driver, but ut refuses either to connect via dhcp or by entering static details
    Tried following: opensuse 10.0, DebianTesting Weekly Build, Archlinux 2008.02 - still no luck

  10. #9
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Does it work under certain kernels, but not others? I am wondering if this is a kernel bug. You could try older kernel versions and see if and when it stopped working.

    If this sounds like de-bugging, well it is. The kernel is constantly being updated with new drivers and things. This has the tendency to sometimes "break' other things in the kernel. That is why I suggested trying older kernels. This may mean trying older distros, as newer ones have newer kernels.

    Then again, if it won't work in SuSE 10.0, which is rather old, then my premise is most likely wrong.
    Please do not send Private Messages to me with requests for help. I will not reply.

  11. #10
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I was looking at the rtl8139 driver in my kernel source and came across something.

    If you go to:
    Device Drivers --->
    Network device support --->
    Ethernet (10 or 100Mbit) --->
    RealTek RTL-8129/8130/8139 PCI Fast Ethernet Adapter support

    There is this option, which is not compiled into the kernel on my build.

    [ ] Use older RX-reset method

    CONFIG_8139_OLD_RX_RESET:

    The 8139too driver was recently updated to contain a more rapid reset sequence, in the face of severe receive errors. This "new" RX-reset method should be adequate for all boards. But if you experience problems, you can enable this option to restore the old RX-reset behavior. If unsure, say N.
    You may need to enable this, and re-compile the kernel. I wonder if the Knoppix kernel has this enabled? NeilJones, is there any way that you can check this?
    Please do not send Private Messages to me with requests for help. I will not reply.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •