Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 12 of 12
Its really strange that it didn't work properly for you. I have successfully used the E220 and E160G from 3 on openSUSE 10.3 and 11.0 as well as Fedora 9. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393

    Its really strange that it didn't work properly for you. I have successfully used the E220 and E160G from 3 on openSUSE 10.3 and 11.0 as well as Fedora 9. One thing I've heard from some individuals is that sometimes you have to use the modem on Windows first, so that the modem part of the dongle is activated instead of just the mass storage. I'm not sure how true this is, but I never had problems with both of the modems because I tried them out on Windows first, so that I could get the correct dialup settings before setting them up on Linux.

  2. #12
    Just Joined!
    Join Date
    Oct 2008
    Posts
    1
    hi there,

    i'm having the same problem as ringo - trying to connect using 3 mobile's huawei e160g modem.

    the software i'm using is umtsmon on opensuse 11.

    here is the log from pppd. the last part is quite similar to what ringo got:

    using channel 6
    Using interface ppp0
    Connect: ppp0 <--> /dev/ttyUSB0
    sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x2b3a2ab7> <pcomp> <accomp>]
    rcvd [LCP ConfReq id=0x14 <mru 1440> <asyncmap 0x0> <auth chap MD5> <magic 0x117eec6> <pcomp> <accomp>]
    No auth is possible
    sent [LCP ConfRej id=0x14 <auth chap MD5>]
    rcvd [LCP ConfNak id=0x1 <mru 1440>]
    sent [LCP ConfReq id=0x2 <mru 1440> <asyncmap 0x0> <magic 0x2b3a2ab7> <pcomp> <accomp>]
    rcvd [LCP ConfReq id=0x15 <mru 1440> <asyncmap 0x0> <magic 0x117eec6> <pcomp> <accomp>]
    sent [LCP ConfAck id=0x15 <mru 1440> <asyncmap 0x0> <magic 0x117eec6> <pcomp> <accomp>]
    rcvd [LCP ConfAck id=0x2 <mru 1440> <asyncmap 0x0> <magic 0x2b3a2ab7> <pcomp> <accomp>]
    sent [LCP EchoReq id=0x0 magic=0x2b3a2ab7]
    sent [CCP ConfReq id=0x1 <deflate 15> <deflate(old#) 15> <bsd v1 15>]
    sent [IPCP ConfReq id=0x1 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
    rcvd [LCP DiscReq id=0x16 magic=0x117eec6]
    rcvd [LCP EchoRep id=0x0 magic=0x117eec6 2b 3a 2a b7]
    rcvd [LCP ProtRej id=0x17 80 fd 01 01 00 0f 1a 04 78 00 18 04 78 00 15 03 2f]
    Protocol-Reject for 'Compression Control Protocol' (0x80fd) received
    rcvd [IPCP ConfNak id=0x1 <ms-dns1 10.11.12.13> <ms-dns3 10.11.12.14> <ms-wins 10.11.12.13> <ms-wins 10.11.12.14>]
    sent [IPCP ConfReq id=0x2 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 10.11.12.13> <ms-dns3 10.11.12.14>]
    rcvd [IPCP ConfNak id=0x2 <ms-dns1 10.11.12.13> <ms-dns3 10.11.12.14> <ms-wins 10.11.12.13> <ms-wins 10.11.12.14>]
    sent [IPCP ConfReq id=0x3 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 10.11.12.13> <ms-dns3 10.11.12.14>]
    Modem hangup
    Connection terminated.
    i know the modem works and coverage is fine because it works on my wife's windows laptop.

    from my log, and from ringo's log, it looks like modem hanged up after sending three IPCP ConfReq packets. from other logs i've seen posted, this should go up to 15-16 times. perhaps opensuse's default settings for pppd makes it timeout too fast? anyway i think i'll try playing with those ipcp-max settings. any other suggestions appreciated

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •