Find the answer to your Linux question:
Results 1 to 6 of 6
Hi! I have a 3com boomerang combo nic with AUI/TP/BNC ports that I can only run in half-duplex (kernel-2.6.22-17.tex2). I would appreciate if someone could help me to get this ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2008
    Posts
    4

    cannot set full-duplex!


    Hi!

    I have a 3com boomerang combo nic with AUI/TP/BNC ports that I can only run in half-duplex (kernel-2.6.22-17.tex2). I would appreciate if someone could help me to get this working...

    I have tried every thinkable fashion to enable full-duplex, but without success.

    # ethtool -s eth0 duplex full
    # ethtool eth0
    Settings for eth0:
    Supported ports: [ TP MII ]
    Supported link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes: Not reported
    Advertised auto-negotiation: No
    Speed: 10Mb/s
    Duplex: Half
    Port: MII
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: off
    Current message level: 0x00000001 (1)
    Link detected: yes

    #rmmod 3c59x && modprobe 3c59x full_duplex=1

    after the following command dmesg says:
    eth0: setting full-duplex

    but again ethtool says it is half-duplex,
    finally...
    #mii-diag
    Using the default interface 'eth0'.
    Basic registers of MII PHY #0: 0000 ffff 0000 ffff 0000 ffff 0000 ffff.
    The autonegotiated capability is 0000.
    No common media type was autonegotiated!
    This is extremely unusual and typically indicates a configuration error.
    Perhaps the advertised capability set was intentionally limited.
    Basic mode control register 0x0000: Auto-negotiation disabled, with
    Speed fixed at 10 mbps, half-duplex.
    Basic mode status register 0xffff ... ffff.
    Link status: established.
    Remote fault detected!
    *** Link Jabber! ***
    Your link partner advertised ffff: Flow-control 100baseT4 100baseTx-FD 100baseTx 10baseT-FD 10baseT, w/ 802.3X flow control.
    End of basic transceiver information.

    In freebsd I can set my nic to full-duplex without any problems, so I can only suspect that the kernel is broken?

  2. #2
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,677
    What is the other end set to?
    Have you verified this?
    Why don't you set auto-negotiation on both ends and see what happens?

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  3. #3
    Just Joined!
    Join Date
    Oct 2008
    Posts
    4
    The other end is an a-link rr44 adsl-router. I have tried to set it to autosense, 10 full and 100 full but it hasn't had any effect whatsoever. I just can't seem to change any option in 3c59x driver. ethtool -s eth0 autoneg on speed 100 duplex full prints nothing to the console, dmesg doesn't show any output and all the rest of the commands such as ethtool -g eth0 return someting like xxx parameter for eth0:
    Cannot get device xxx settings: Operation not supported

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,677
    You either set autoneg on or lock it down, not both.
    Do you have another device that you could connect to this device to check which one is not working as expected?

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  6. #5
    Just Joined!
    Join Date
    Oct 2008
    Posts
    4
    Verified!
    Booted Freebsd and ran ifconfig xl0 media utp mediaopt full-duplex and it worked. ifconfig shows that xl0 is in 10baseT full-duplex mode.

    mii-tool --force=10baseT-FD, ethtool -s eth0 autoneg on tried. Nothing works, the problem is in the kernel or the associated utilities?
    Only solution I can think of is to dig an old Redhat Linux 7.0 install cd from my archives, install it and see if it can put my nic full duplex mode...??

  7. #6
    Just Joined!
    Join Date
    Oct 2008
    Posts
    4

    Still there lazydog?

    I finally gave up getting this nic to work like I want it to...
    anyway I suspect it might be some acpi related bug since when I boot the kernel floods my screen with message like pci_set_power_state(): 0000:00:0a.0: state=3, current state=5
    the following line also is in the kernel output (don't know if it is of any importance) ACPI: PCI Interrupt 0000:00:0a.0[A] -> GSI 17 (level, low) -> IRQ 16

    anyway, I'll use it as it is for now. It is anyway very dated hardware and I need to upgrade anyway...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •