Find the answer to your Linux question:
Results 1 to 2 of 2
Hi 'body, I have a strange issue: I've installed net-snmp 5.3.1 on a RH Linux 2.6.18-8.el5PAE i686 i686 i386 GNU/Linux net-snmp 5.4.1 on a Ubuntu Hardy 2.6.24-16-generic x86_64 GNU/Linux once ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2008
    Posts
    4

    NET-SNMP: Timeout: No Response from 127.0.0.1.


    Hi 'body,
    I have a strange issue:
    I've installed
    net-snmp 5.3.1 on a RH Linux 2.6.18-8.el5PAE i686 i686 i386 GNU/Linux
    net-snmp 5.4.1 on a Ubuntu Hardy 2.6.24-16-generic x86_64 GNU/Linux

    once started the service (service snmpd start) both installations act the same:
    #snmptranslate .1.3.6.1.2.1.1.3.0
    DISMAN-EVENT-MIB::sysUpTimeInstance
    #snmpget -v 2c -c root-community 127.0.0.1 SNMPv2-MIB::sysUpTime.0
    Timeout: No Response from 127.0.0.1.

    in snmpd.log I can see that snmpd receives requests each time:
    Connection from UDP: [XXX.XXX.XXX.XXX]:XXXXX

    using "ps aux" i can see that snmpd is started with this line:
    /usr/sbin/snmpd -Lsd -Lf /var/log/snmp.log -p /var/run/snmpd -a

    Stopping that service, when I tryied to start it directly from command line:
    #/usr/sbin/snmpd -Lsd -Lf /var/log/snmp.log -p /var/run/snmpd -a

    I get response! Every snmpget request is served!

    What is happening there?

  2. #2
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    Please post your thread in only one forum. This thread is closed because its a duplicate.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •