Find the answer to your Linux question:
Results 1 to 5 of 5
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Angry Home Networking Issue


    I have 2 machines 1 running windows and 1 running linux centOS.

    Both machines are connected to a modem/router provided by my ISP.

    TRIED TO: Create a network where both machines are connected in order to access the services running on centOS from the windows machine.

    - Assigned a static IP to the Linux machine (e.g.
    - Configured Samba and other services

    - I could not access the Linux machine from the windows machine (from the network places) / or map a network drive from the windows machine to the Linux machine.

    - Basically i cannot access any of the services running on the linux machine (even if i enter the IP address of the linux machine - e.g. http://IP_OF_LINUX_MACHINE/ )

    - Note that both machines are on the following IP range -

    Any help appreciated.


  2. #2
    There could be a number of things stopping you getting at your Cent box.

    First things first try reading this article on setting up samba Quick and dirty Samba setup

    What error message are you getting?

  3. #3


    Thanks for taking the time to check the post and answer.

    I just cannot access the services, e.g. httpd : I get a "server

    connection failed"

    As for the samba config article you recommend reading, i did that but with no results.

    I know i am doing something wrong, the thing is to find out what..

    Thanks again for your time.

  4. $spacer_open
  5. #4
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Nottingham, England
    You should connect to the linux server using the samba incantation. If you use http://... then you're connecting to the web server, and you'd need a package like apache configured to connect that way.

    On the windwos machine, try doing 'start->run' and typing "\\<linux-machine-name>" or "\\<linux-machine-ip-address>".
    Linux user #126863 - see

  6. #5
    I would take a guess that iptables could be blocking you connections, a quick test to prove this is just to stop the service, so

    sudo /etc/init.d/iptables stop
    and try to connect again.

    If this doesn't work you could check you Linux box is listening on port 80 (web) by running;

    netstat -l |grep www
    netstat -l |grep 80

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts