Find the answer to your Linux question:
Results 1 to 3 of 3
Hey everyone, I have a bit of a long term problem, which is that i can connect to the internet (via a LAN) but cant reach Google . Youtube loads ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2008
    Posts
    4

    Internet Problem! (all Linux Flavours)


    Hey everyone,

    I have a bit of a long term problem, which is that i can connect to the internet (via a LAN) but cant reach Google.

    Youtube loads at the rate of 128kb/s as does just about any other site inc:
    Yahoo, LinuxForums, LinuxMint, linux-sound, alsa-project etc etc.

    I think that the problem might be with translating the "name" of the server
    ie server1.google.ie to its IP address...?? Sounds crazy.. and im not an expert
    here by any means.. but that's the most i can figure!

    Most sites work, some dont. Google, archive.ubuntu.com, MSN server wont work.
    they bring up a "Page Load Error"(Using Firefox)

    Firefox can't find the server at Google.
    The browser could not find the host server for the provided address.
    # Did you make a mistake when typing the domain? (e.g. "ww.mozilla.org" instead of "www.mozilla.org")
    # Are you certain this domain address exists? Its registration may have expired.
    # Are you unable to browse other sites? Check your network connection and DNS server settings.
    # Is your computer or network protected by a firewall or proxy? Incorrect settings can interfere with Web browsing.
    I dont have any particular firewall, just the default with Suse,Ubuntu, LInuxMint or live Cd's.

    (now the most painful part)
    If i run Windows XP in a virtual machine, it CAN connect trough everything, which (as far as i know) rules out the hardware error.

    (and to confuze things even more)
    Once in a while, apparently quite random to me, it just decides it will work for one boot's duration!?!?

    ANY help appreciated, i have a Acer TM 5270 laptop, and a custom PC, BOTH have the problem. Lan Adapters are Broadcom and an NForce 4.

    Thanks, -Harry van Haaren

  2. #2
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,677
    Are you using FQDN?

    What do the following files look like;


    1. /etc/resolv.conf
    2. /etc/hosts

    Can you run DIG on the hosts that are not working and post the output?

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  3. #3
    Just Joined!
    Join Date
    Nov 2008
    Posts
    4

    Thanks for your response!

    Hey,

    thanks for the suggestions.. i've had some experience with /etc/hosts and resolve.conf due to sudo problems, theyre' perfect, not running FQDN, but its all ok, because i loaded DreamLinux off a CD, and it runs the internet perfect once i manually configured it..? Must be to do with it being based on Debian Lenny rather than Etch (most other distro's that i tried were).
    Newer Kernel or Networking modules must have fixed it because it runs!

    If it breaks again ill be back here, but for now, problem magically solved!
    Peace and thanks for the response, -Harry

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •