Find the answer to your Linux question:
Results 1 to 7 of 7
This is my first post here, so if I am doing something wrong please tell me ! I am planning to learn more about Linux, and have installed Fedora Core ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2004
    Posts
    7

    Newbie: Wireless on Fedora 2, can't ping my Linksys router !


    This is my first post here, so if I am doing something wrong please tell me !


    I am planning to learn more about Linux, and have installed Fedora Core 2 on a dual boot system together with Windows XP pro.

    Because linux isn't linux without internet, I would like to go online with Fedora. However, I connect to the internet using a wireless card (Linksys: WMP54G), and there is no appropriate linux driver for this device.

    After some searching, I tried to get everything working with the ndiswrapper, following a tut. I found on the internet. Most of the instructions went just fine, but I can't seem to ping my router (a linksys WRT54G, local IP: 192.168.1.1)

    Can someone please help me?

    -------------------------------------------------------------------------------

    Some command print outs:
    (PS: with the route command I did see my router's IP address)

    [root@localhost root]# ifconfig wlan0
    wlan0 Link encap:Ethernet HWaddr 00:0C:41:61:A9:A4
    inet addr:192.168.1.101 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::20c:41ff:fe61:a9a4/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:12 errors:0 dropped:0 overruns:0 frame:0
    TX packets:107 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:2203 (2.1 Kb) TX bytes:10582 (10.3 Kb)
    Interrupt:5 Memory:e6000000-e6001fff

    [root@localhost root]# ping 192.168.1.1
    PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.

    --- 192.168.1.1 ping statistics ---
    102 packets transmitted, 0 received, 100% packet loss, time 101008ms

    [root@localhost root]# iwconfig wlan0
    wlan0 IEEE 802.11g ESSID:"linksys" Nickname:"localhost.localdomain"
    Mode:Managed Frequency:2.462GHz Access Point: 00:0C:41:AA:EA:88
    Bit Rate=36Mb/s Tx-Power:14 dBm
    RTS thr=2347 B Fragment thr=2346 B
    Encryption keyff
    Power Managementff
    Link Quality:100/100 Signal level:-69 dBm Noise level:-256 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:19 Invalid misc:54 Missed beacon:0

    -------------------------------------------------------------------------------

    My etc/sysconfig/network-scripts/ifcfg-wlan0 bestand:

    # NDIS Wrapper Configuration: Linksys WMP54G
    DEVICE=wlan0
    onBOOT=yes
    BOOTPROTO=dhcp
    TYPE=Wireless
    MODE=Managed
    ESSID=linksys
    CHANNEL=11
    USERCTL=yes
    PEERDNS=no
    RATE=Auto
    NETMASK=
    DHCP_HOSTNAME=
    IPADDR=
    DOMAIN=
    HWADDR=00:0c:41:61:a9:a4
    GATEWAY=
    IPV6INIT=yes

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    make sure you have your router set up to reply to pings originating from inside the LAN. i know that sounds stupid but sometimes that's all it takes!
    -lakerdonald

  3. #3
    Just Joined!
    Join Date
    Sep 2004
    Posts
    7
    I can now ping the router (a standard setting was blocking nameless pings)

    However, I can still not ping sites (www.google.nl) nor surf.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    well that's good news. can you ping 216.239.39.104 (google.nl) by doing
    Code:
    ping 216.239.39.104
    instead of
    Code:
    ping google.nl
    cos if you can, that means that you simply have a problem with your DNS server and need to correctly configure your router to do so
    -lakerdonald

  6. #5
    Just Joined!
    Join Date
    Sep 2004
    Posts
    7
    The IP address ping worked, and the other one didn't.

    Thus I figgured it must be a DNS problem. I found the solution online, it involved editing my /etc/resolve.conf file.

    /etc/resolve.conf

    OLD:
    search localdomain

    NEW:
    search localdomain
    nameserver 194.134.5.5
    nameserver 194.134.0.97


    Now I can go online !

    Thank you very much for your help.

    PS: I am typing this from Firefox running on Fedora Core 2.

  7. #6
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    No Problem.After spending two months trying to get wireless to work, i empathize with your position. lol
    -lakerdonald

  8. #7
    Just Joined!
    Join Date
    Oct 2004
    Posts
    1

    Wireless troubles

    I'm also have a ton of issues getting my wireless working under FC2.

    Dell Latitude D600, so it uses the Broadcom set. I installed ndiswrapper, loaded the appropriate drivers, and went through all the installation steps.

    What I have now:

    1) iwlist scan shows all the wireless networks i should be able to see.
    2) iwconfig shows my wlan0 config, seemingly correct (with the right essid, access point MAC address, signal strength, etc).
    3) ifconfig wlan0 seems to work

    The problem is that I cannot ping the wireless router! I'm using a Linksys, and it works fine with windows machines around, but I cannot get any pings to work at all. I can see the wireless network, and I seem to have the wlan0 device set up, but pings don't respond.

    I've googled and googled but have found nothing that helps.

    So if I've successfully done all the iwconfig and ifconfig stuff and it seems like it's all set up and should work, but I cannot ping my wireless router or anything else, what would be the problem?

    The wireless router is 192.168.1.1, so I manually assigned wlan0 an IP of 192.168.0.13 (dhclient doesn't work - just times out).

    This is so frustrating!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •