Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
I am running Fedora Core 2 on machine A(IP=10.0.0.12); I am running Windows XP SP2 on machine B(IP=10.0.0.16; NAME=Phoenix); I can connect to the share(s) of my linux machine from ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2004
    Location
    Tunbridge Wells, Kent, TN4 9UU, ENGLAND
    Posts
    6

    cannot connect to windows shares from linux


    I am running Fedora Core 2 on machine A(IP=10.0.0.12);
    I am running Windows XP SP2 on machine B(IP=10.0.0.16; NAME=Phoenix);
    I can connect to the share(s) of my linux machine from windows machine B, am able to view the entire filesystem of my linux machine A.
    I also have other windows machines and they can view the shares of my windows machine B.
    My problem is that i cannot access the shares of my windows machine B, from my linux machine A.
    When i click to open 'Network Servers' the box(window) comes up and has an icon for 'Windows Network', when i click on that icon, it opens another box(window), but there is nothing in it...??
    Now when i try to mount a share of my windows machine B from the command line in Linux; here is what i type:
    'mount -t smbfs -o username=Phoenix\slink,password=******* "//Phoenix/sata3c" /mnt/sata3C'
    this then comes up with the following error:
    'Error connecting to 10.0.0.16 (Connection refused)
    3573: Connection to Phoenix failed
    SMB connection failed'

    the number in the above error message changes each time i execute that command.

    I have firewall software on my windows machine B, and i have set it to allow any traffic from my ethernet(LAN) card, it still refuses the connection from my linux machine A. I have tried dissabling all firewall software on my windows machine A, but still it doesnt allow connection from linux.

    Its wierd because all my other windows machines on my network can connect to windows machine B..??

    Any ideas , please reply, or e-mail me..
    Thanks, tIm(phoix)

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    i recently had a similar problem, and my solution made absolutely no sense. for some reason, it would work when i just did
    Code:
    smbmount "\\Desktop\C" ~/C
    and then entered a password at the prompt instead of:
    Code:
    smbmount -o username:paladin,etc... "\\Desktop\C" ~/C
    strange eh? try it, it might work?

  3. #3
    Just Joined!
    Join Date
    Sep 2004
    Location
    Tunbridge Wells, Kent, TN4 9UU, ENGLAND
    Posts
    6

    Still problem with connecting to windows shares

    no, i get the exact same message as before;
    connection refused..

    hmmm...

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Sep 2004
    Posts
    3
    I have the same issue as phoix. I can see my linux machine and access the share from the windows boxes and I can see all my windows machines from my linux box but I cannot access any shares.

    I am running XP SP1 on all my windows desktops (3 of them) and a windows 2003 server. I have a domain set up with active directory. I run Fedora Core 2 on my linux machine and when I try to access the windows shares from the network browser in the GUI I can see all my windows machines but get this error when I try to view the shares:

    "You do not have the permissions necessary to view the contents of "Windows Network: computername".

    I have the same root UN/PW and the same user UN/PW on my linux box as my windows box.

    If I run it from the command line I get:

    sudo smbmount //192.168.1.2/Robin/ /mnt/robin/
    cli_negprot: SMB signing is mandatory and we have disabled it.
    11719: protocol negotiation failed
    SMB connection failed

    I believe this has something to do with cifs but I checked the kernel and it is in there. I have been looking for a few weeks to resolve this but no luck yet.

    Both of those are when I try to access my 2003 server. I get a little different error when I try my XP box from a command line. I'm short on time at the moment but I will try to post the results of that later. (It reads the same error in the network GUI though)

    Edit: I noticed that phoix is also running FC2. IMO this is where the problem lies. I was previously running Slack 10 and samba worked perfect in this set up once I got CIFS working.

  6. #5
    Just Joined!
    Join Date
    Sep 2004
    Posts
    3
    Well I have been successful in finally getting my Fedora box into my 2k3 domain. However I still get an error when trying to browse my Windows shares Any suggestions are appreciated.

  7. #6
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    hmm, there are alot of odd permissonons stuffs, download and isntall webmin, it will make this a little easier. Also, maybe you should just attach it to the domain that all the ms machines are linke to?
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  8. #7
    Just Joined!
    Join Date
    Sep 2004
    Posts
    3
    I did get the FC2 box joined into the 2k3 domain....

    I was speaking to another person that I know about this and he is running slack 10. He has the same problem in Gnome where he can't view the shares on a Windows domain via the GUI.

    Then we found this: https://bugzilla.redhat.com/bugzilla....cgi?id=123899

    Seems to be a Gnome issue. I can actually now get to my Windows shares if I type the address in Nautilus. Guess I wait for a fix

  9. #8
    Just Joined!
    Join Date
    Sep 2004
    Posts
    28
    Try giving permission to everyone for everything on your windows shares. WinXP Pro can cause problems in sharing when the workgroup or domain differs for usernames.

  10. #9
    Just Joined!
    Join Date
    Oct 2004
    Posts
    1
    Been there seen it done it... banged head against brick wall for days.

    Answer... there is a bug in the kernel that ships with FC2. Get the newer one from the Red Hat Fedora Development tree.. install and hey presto!!

  11. #10
    Just Joined!
    Join Date
    Oct 2004
    Posts
    19
    Answer... there is a bug in the kernel that ships with FC2. Get the newer one from the Red Hat Fedora Development tree.. install and hey presto!!
    Forgive my ignorance and apparent stupidity, but how do I achieve that exactly?, where is the 'development tree'

    ...and why does this not get sorted with the plethora of updates that I had to do?

    I have the same problem, being new to Linux I would like to still access my other Windows workgroup machines, preferably before all my hair is gone.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •