Find the answer to your Linux question:
Results 1 to 10 of 10
Greetings all... a search for my problem returns only one hit: http://www.linuxforums.org/forum/lin...tml#post345926 My error message is identical (error 13) but, needless to say, attempting all the offered solutions doesn't work. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie sarlacii's Avatar
    Join Date
    May 2005
    Location
    South Africa
    Posts
    110

    Unhappy SMBFS and CIFS mount error


    Greetings all... a search for my problem returns only one hit:
    http://www.linuxforums.org/forum/lin...tml#post345926

    My error message is identical (error 13) but, needless to say, attempting all the offered solutions doesn't work. :o(

    Issue:
    Need to mount a remote win server 2003 share... //192.200.200.10/user on /mnt/drv. The username=user, password=pass, domain=company,workgroup=local.

    Now, the command mount -t cifs -o username=user,password=pass //192.200.200.99/Public /mnt/public works perfectly with our gentoo box running smbd v3.0.27a. Share mounts and is accessible.

    The same command with the win 2003 share... mount -t cifs -o username=user,password=pass //192.200.200.10/user /mnt/drv gets the following error:

    mount error 13 = Permission denied
    Refer to the mount.cifs( manual page (e.g.man mount.cifs)
    Modifying the command to use smbfs instead (i.e. same command as above, but with "-t smbfs") gets the following error:

    cli_negprot: SMB signing is mandatory and we have disabled it.
    14216: protocol negotiation failed
    SMB connection failed
    Okay then... what one Earth does that mean? Missing kernel parameter or messed up smb config perhaps?

    Interestingly, if I open the same share in kde with url smb://user@fileserver/user where "fileserver" is the name for 192.200.200.10, the share opens up perfectly... files all there, can copy things back and forth. Sigh. I need a permanent mount point though... .

    Settings for samba were done via the kde control panel, can post if that is required... but since this is a smbmount client issue, then smbd conf shouldn't affect things, right?

    Kernel-wise, I was using the PClinuxOS 2007 original kernel (2.6.18.8.tex5) but then upgraded to 2.6.22.17.tex2 to see if that solved things. No go... still bust. Perhaps I need 2.6.24, but it's not available in PClinuxOS repos.

    Any ideas folks?
    Respectfully... Sarlac II
    ~~
    The moving clock K' appears to K to run slow by the factor (1-v^2/c^2)^(1/2).
    This is the phenomenon of time dilation.
    The faster you run, the younger you look, to everyone but yourself.

  2. #2
    Linux Newbie sarlacii's Avatar
    Join Date
    May 2005
    Location
    South Africa
    Posts
    110
    Hmm, lots of posts around this issue. Will have to try some of the proffered solutions, but the issue appears to be kernel related, as of 2.6.18 onwards.

    See Vijay Kumar's Blog: Cifs "mount error 13 = Permission denied" which links to the bugzilla post for the issue.

    Lots of noise on this one... :o) time to go play around. Will report my findings.
    Last edited by sarlacii; 01-09-2009 at 07:19 PM. Reason: link did not show

  3. #3
    Just Joined!
    Join Date
    Jan 2009
    Posts
    2
    ya might want to give this a shot:

    echo 0 > /proc/fs/cifs/LinuxExtensionsEnabled

    and then retry.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie sarlacii's Avatar
    Join Date
    May 2005
    Location
    South Africa
    Posts
    110
    Hmm, thanks JM_Stoorvogel, this is something that I have not seen in any of the other postings. I'll give it a try. Shot.

  6. #5
    Just Joined!
    Join Date
    Jan 2009
    Posts
    2
    Quote Originally Posted by sarlacii View Post
    Hmm, thanks JM_Stoorvogel, this is something that I have not seen in any of the other postings. I'll give it a try. Shot.
    if /proc/fs/cifs/LinuxExtensionsEnabled does not exist you should load the cifs driver. This is done automatically when trying to mount a cifs share. If you want to automate this, add to your /etc/init.d/smbfs:

    in the starting section, "modprobe cifs", and then add the line:
    echo 0 > /proc/fs/cifs/Li~


    If things still don't work, present us a log, like

    cat /var/log/messages | grep mount > somefile
    tail -n 30 somefile'


    (aka: show last 30 lines in /var/log/messages containing string "mount")

  7. #6
    Linux Newbie sarlacii's Avatar
    Join Date
    May 2005
    Location
    South Africa
    Posts
    110
    Right... some intensive research has identified the problem. Now that I am searching with the correct terms, I suddenly see that the issue is very common.

    Basically, checking out either cifs debug info at /proc/fs/cifs/DebugData or else tail -n 30 /var/log/messages or just thinking about the smb error message ("cli_negprot: SMB signing is mandatory and we have disabled it.") gives the problem... SMB signing.

    See Overview of Server Message Block signing for a description of the MS side of things. Research shows that smbfs did not support signing, so the easiest solution was to simply turn it off in win servers. If you do not want to do that, then cifs does support it.

    Cool... the problem now is that neither smbfs nor cifs will mount the share. Both complain of SMB Signing errors. Cool. We cannot turn off signing in the servers, so that is not an option either.

    So I tried the old "smbclient -L <ip> -U user" thing, and hey presto, the list of shares available on the server comes up. I then tried "smbclient //company-fs/username -U username" (which is basically a connect to a user's private directory on the server) and the share connected!!! All directories browseable and files can be transferred. No SMB signing errors.

    Sigh. The war continues.

  8. #7
    Linux Newbie sarlacii's Avatar
    Join Date
    May 2005
    Location
    South Africa
    Posts
    110
    Okay, for the record (I feel a tutorial coming on here!) I have worked something else out now.

    Using cifs still gives the same SMB Signing issues ("Unexpected Signature" says the messages log). No new info here.

    However, as reported previously above, using the command "smbclient //server/share -U username" works fine. A bit of extra digging revealed that smbclient has a switch "-S" (note capital "S", the lower-case is -s <smb config file>) that allows SMB Signing to be controlled at the command-line. This switch does not appear in any of the man pages! I came across a posting ion the samba mailing-list that mentioned it's existance. So, the test:

    smbclient //server/share -U username -S off
    results in the usual error "cli_negprot: SMB signing is mandatory and we have disabled it etc. etc.". Using however
    smbclient //server/share -U username -S on
    results in the share being accessed correctly, just as happens when the switch is left out. So, smbclient enables signing by default.

    Okay, so I checked up on SMB Signing in the smb.conf file. Wow, there are two options, "client signing = <x>" and "server signing = <x>", where <x> is either "Auto", "Mandatory" or "Disabled". Unsurprisingly, setting these options makes absolutely no difference at all to the result of a "mount -t smbfs //<ip>/share /mnt/whatever -o username... etc.". Wierd.

    I will now try to track down the samba guys and ask them about their secret "-S" switch, and why their mount.smbfs command ignores the settings in smb.conf.

    May the force be with us!

  9. #8
    Just Joined!
    Join Date
    Feb 2009
    Posts
    11
    My /etc/fstab
    //x.x.x.x/netapp /urs/share cifs username=guest,password=guest,defaults 0 0

    #mount -a
    It gives no error and mount the drive
    But after rebooting there is nothing mounted

    Can any one help on this?

  10. #9
    Linux Newbie sarlacii's Avatar
    Join Date
    May 2005
    Location
    South Africa
    Posts
    110
    Quote Originally Posted by sanuu View Post
    <snip>
    But after rebooting there is nothing mounted
    <snip>
    Hi sanuu

    I am not sure why this is, but I have the same issue. I have now succeeded in getting the drive to mount, but it does not mount automatically at boot either. I have not looked into it, as I ran out of time - I just put together a script that mounts the drives manually, and shoved it into my kde Autostart directory.

    I'll let you know if I find anything out when I get a chance to look at it. But for now, the BFG workaround is a script. :o)
    Respectfully... Sarlac II
    ~~
    The moving clock K' appears to K to run slow by the factor (1-v^2/c^2)^(1/2).
    This is the phenomenon of time dilation.
    The faster you run, the younger you look, to everyone but yourself.

  11. #10
    Linux Newbie sarlacii's Avatar
    Join Date
    May 2005
    Location
    South Africa
    Posts
    110

    Cool [SOLVED - with workaround]

    Okay, the solution for me (after trying various security flags in cifs with no luck, and even the various options on the Win2000 file server) was to mount the shares as the domain admin. Seriously... .

    Well, that's as far as I got... kde still works perfectly from konqueror with my actual domain user credentials, but cifs only mounts with the admin user and pass. LOL What a saga.

    So... solved, sort of.
    Respectfully... Sarlac II
    ~~
    The moving clock K' appears to K to run slow by the factor (1-v^2/c^2)^(1/2).
    This is the phenomenon of time dilation.
    The faster you run, the younger you look, to everyone but yourself.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •