Hello,

i am trying to debug an issue i am experiencing while trying to establish a pptp connection to windows 2003 server through my linux machine. My linux kernel is 2.6.10 with mppe/mppc support enabled. pppd package is ppp-2.4.4b1 and pptp package is pptp-1.7.0. since i am new to this, i am posting this to seek your opinion/suggestion over the issue.
The issue is when i try to connect to the aforesaid server the i am not able to get it done. With linux pptp server i am able to get the ip from the server without any problem at all.

for you reference i have a pasted the logs on the client side.
--------------------------------------------------------------------------------------------------------------------------------
2009 Feb 3 14:26:30 [FVX538] [pppd] pppd 2.4.4b1 started by root, uid 0
2009 Feb 3 14:26:30 [FVX538] [pppd] Starting connection
2009 Feb 3 14:26:30 [FVX538] [pppd] using channel 855
2009 Feb 3 14:26:30 [FVX538] [pppd] Using interface ppp0
2009 Feb 3 14:26:30 [FVX538] [pppd] Connect : ppp0 <--> /dev/ttyp0
2009 Feb 3 14:26:30 [FVX538] [pptp] anon log[main : pptp.c:267]: The synchronous pptp option is NOT activated_
2009 Feb 3 14:26:30 [FVX538] [pptp] anon log[ctrlp_rep : pptp_ctrl.c:251]: Sent control packet type is 1 'Start-Control-Connection-Request'_
2009 Feb 3 14:26:30 [FVX538] [pptp] anon log[ctrlp_disp : pptp_ctrl.c:738]: Received Start Control Connection Reply
2009 Feb 3 14:26:30 [FVX538] [pptp] anon log[ctrlp_disp : pptp_ctrl.c:772]: Client connection established.ppp-2.4.4b1
2009 Feb 3 14:26:31 [FVX538] [pppd] sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xdc13d24f> <pcomp> <accomp>]
2009 Feb 3 14:26:31 [FVX538] [pptp] anon log[ctrlp_rep : pptp_ctrl.c:251]: Sent control packet type is 7 'Outgoing-Call-Request'_
2009 Feb 3 14:26:31 [FVX538] [pptp] anon log[ctrlp_disp : pptp_ctrl.c:857]: Received Outgoing Call Reply.
2009 Feb 3 14:26:31 [FVX538] [pptp] anon log[ctrlp_disp : pptp_ctrl.c:896]: Outgoing call established (call ID 0, peer's call ID 45768 ) ._
2009 Feb 3 14:26:34 [FVX538] [pppd] sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xdc13d24f> <pcomp> <accomp>]

2009 Feb 3 14:26:40 [FVX538] [pppd] Terminating on signal 15

2009 Feb 3 14:26:40 [FVX538] [pppd] sent [LCP TermReq id=0x2 "User request"]
2009 Feb 3 14:26:40 [FVX538] [pptp] anon log[callmgr_main : pptp_callmgr.c:255]: Closing connection (shutdown)
2009 Feb 3 14:26:40 [FVX538] [pptp] anon log[ctrlp_rep : pptp_ctrl.c:251]: Sent control packet type is 12 'Call-Clear-Request'_
2009 Feb 3 14:26:40 [FVX538] [pptp] anon log[ctrlp_disp : pptp_ctrl.c:928]: Call disconnect notification received (call id 0)
2009 Feb 3 14:26:40 [FVX538] [pptp] anon log[ctrlp_error : pptp_ctrl.c:199]: Result code is 0 'Unknown Result Code'. Error code is 0, Cause code
is 0
2009 Feb 3 14:26:40 [FVX538] [pptp] anon log[call_callback : pptp_callmgr.c:78]: Closing connection (call state)
2009 Feb 3 14:26:40 [FVX538] [pppd] Child process pptp 192.168.1.65 --nolaunchpppd (pid 473) terminated with signal 15
2009 Feb 3 14:26:40 [FVX538] [pppd] Modem hangup
2009 Feb 3 14:26:40 [FVX538] [pppd] Connection terminated.
2009 Feb 3 14:26:40 [FVX538] [pppd] Exit.
--------------------------------------------------------------------------------------------------------------------------------
it looks to me that LCP negotiation is not getting completed. Can anybody please tell me where/how i should probably dig for a fix here.

i'll appriciate any comment/suggestion/opinion/direction or any valid/invalid related pointer/link

Thanks,
kapsikum