Hi all,

I am in the process of enabling WLAN for a target board. It has a WLAN Bluetooth (WLAN-BT) combo module SP-W8ME-A from MuRata which has a Marvell WLAN (88W8686) + CSR Bluetooth chipset.

The target runs on OMAP3 with WLAN brought up using the following setup,

Driver: Marvell libertas 8686 WLAN Driver
Firmware Version: fw 9.70.3p14
Linux Kernel Version: 2.6.22.18

With the above setup I am able to:

1) insmod libertas driver.

2) Load the firmware successfully (by the driver).

3) 'iwconfig' command shows me the following:

eth1 IEEE 802.11b/g ESSID:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power=18 dBm
Retry limit:8 RTS thr=2347 B Fragment thr=2346 B
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

4) 'ifconfig' shows me that the interface is setup fine too.

Now I want to scan for networks, here I get into trouble.

5) 'iwlist' eth1 scan tells me 'No scan results'

I have setup test access points, so I am sure of getting at least one result.

I have tried scanning in both Managed and AdHoc mode and also on different channels.

My target always gives me a login shell with root access by default.
(So sudo is not required for iwlist as expected by some systems.)

The following are my concerns/queries:

a) What might be the possible cause of getting no results?

b) Is it that the libertas driver will not work for WLAN-BT modules?
(Scan works fine on other WLAN (8686) module without Bluetooth, so wireless tools seems to work fine.)

c) Can Bluetooth co-existence cause any problem?


Please help me fix this issue. (Post queries if you require any further clarification on the setup)


Thanks in Advance

Ruchi