Find the answer to your Linux question:
Results 1 to 6 of 6
Hello guys..... question(s)... I run into a problem when trying to use my XP as VNCViewer and my Fedora 10 as VNCServer I installed VNC server and client in both ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2009
    Posts
    3

    Smile VNC on FC and XP


    Hello guys..... question(s)...

    I run into a problem when trying to use my XP as VNCViewer and my Fedora 10 as VNCServer

    I installed VNC server and client in both my XP and Fedora. If I am using Fedora VncViewer through XP, it runs with no problem. But not the otherway around? (XP vncviewer to FC)

    Yes..... I know this happens a lot and I can google it, but I googled it with no luck!

    IP address for my Fedora is 10.0.10.148

    I run VncServer in Fedora by typing 'vncserver' or 'vncserver :1', and comes out with the display screen number (1) and the log file. I checked the log file and there are a few errors. (see attached)

    I run VncViewer from XP, type in 10.0.10.148:1 and still got "Connection refused (10061)' (please see attached again).

    I attached the startup file as well for you to see.

    Port 5900 TCP and UDP are open, I can ping from XP to Fedora, I can telnet, but I can't VNC.

    Please assist me if you all know what's going on =) as I am desperate

    Thanks,
    Hartono
    Attached Images Attached Images

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,885
    Is the VNC service running? Type 'service vncserver status' to find out.

    If you've not configured it, you need to:

    1. set up a vnc session in /etc/sysconfig/vncservers. I forget the actual syntax but you add a line like '1:username' to create screen 1 as user 'username'. Dont worry, the comments in that file will tell you what format to use.

    2. run vncpasswd for that user you specified. Choose a good password, your vnc session remains running - and you want to protect it.

    3. inside that user's ~/.vnc directory, create a file called xstartup with a line in it like 'startkde' or 'startxfce' (or whatever windowing system you want to use)

    4. start the vnc service again with 'service vnc restart'. You should see confirmation that the user's vnc session is starting.

    5. connect as normal.

    6. if you want your vnc desktop to restart on reboot, do 'chkconfig vncservice on' at the command line.

    You might also find you have to ensure port 5901 is open (as 5900 relates to screen 0 ).
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Just Joined!
    Join Date
    Apr 2009
    Posts
    3
    I typed 'service vncserver status'
    it only said Xvnc is stopped, so I edited the startup file with 'gnome' added, then saved it, and I typed 'service vncserver restart' (see attached) and typed 'service vncserver status' again, and it still says 'Xvnc is stopped"

    How do I ensure if port 5901 is really open and listen? I went to System->Firewall-> on trusted port I added 5900 and 5901 both with TCP/UDP. I did netstat and it only shows me 5900 LISTEN but no 5901. Could it be because port 5901 is not listening? How do I open it?

    When I tried to kill the service using 'vncserver -kill :1', it says
    "Cannot find file ..(something)..
    "You'll have to kill Xvnc manually"

    I removed the .log as it gets too messy inside, when the vncserver restarted, it gets recorded to a new .log, but the log file now is empty?

    Cheers,
    Attached Images Attached Images

  4. #4
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,885
    Did you do the VNC password thing for your chosen user?

    netstat will show active connections.

    Dont kill the service with 'vncserver -kill ...' unless you have a problem. Try to use the service controls, i.e. 'service vncserver stop'.

    You cant start gnome with the command 'gnome &' at the end of your file. It's something like 'gnome-panel', and you shouldn't be running that alongside twm.
    Linux user #126863 - see http://linuxcounter.net/

  5. #5
    Just Joined!
    Join Date
    Apr 2009
    Posts
    3
    Thanks for the reply,

    Yes, I put the password in.

    I changed it to "gnome-session & " and commented "twm &", still not working.
    I received a lot of "fixed font" error, and I looked it up at google and some says, X will not working if font server is not up and running.

    Now I am thinking, does this have anything to do with VncViewer "error: Connection refused 10061"?
    Which one should I solve first?

    Please see attachment for my log file.

    Cheers,
    Attached Images Attached Images

  6. #6
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,885
    You could be missing some packages to make X work properly. It says you've not got GTK+ and a simple fonts package.

    But that shouldn't stop your VNC server from working - even if it cant display your chosen desktop environment, it should still show the plain grey X view with the X mouse cursor.

    At first, I'd go back and check your firewall settings for the Linux machine to find out if connections are being blocked. Also check your client machine to be certain it's allowing outgong connections to that port on the Linux machine.
    Linux user #126863 - see http://linuxcounter.net/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •