Find the answer to your Linux question:
Results 1 to 4 of 4
Hi everyone I'm using GNU/LinEx (based on Debian) on a DELL Inspiron 8500 and I've tried to connect to the Internet through a Conceptronic PCMCIA modem (model C56CLS) using GNOME ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2004
    Location
    Galiza
    Posts
    8

    connexion with PPP through PCMCIA modem - PPP: Not enabled


    Hi everyone

    I'm using GNU/LinEx (based on Debian) on a DELL Inspiron 8500 and I've tried to connect to the Internet through a Conceptronic PCMCIA modem (model C56CLS) using GNOME PPP.

    The thing is I've tried several options:
    -just entering the phone number, the password and user name;
    -either selecting /dev/modem or /dev/ss0ty1, which is the device selected when I press "Detect"
    -also entering my IP, the domain name, DNS 1 and DNS 2...

    but the result is always the same. Here's the log file produced when it's trying to connect:


    Code:
    --> WvDial: Internet dialer version 1.54.0
    --> Initializing modem.
    --> Sending: ATZ M1L3
    ATZ M1L3
    OK
    --> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    OK
    --> Modem initialized.
    --> Sending: ATDT908200025
    --> Waiting for carrier.
    ATDT908200025
    CONNECT 115200
    --> Carrier detected.  Waiting for prompt.
    .TdE PROHIBIDO CUALQUIER ACCESO NO AUTORIZADO .
    Login: 
    --> Looks like a login prompt.
    --> Sending: telefonicanet@telefonicanet
    telefonicanet@telefonicanet
    Password: 
    --> Looks like a password prompt.
    --> Sending: (password)
        PPP: Not enabled
    ascend% 
    --> Hmm... a prompt.  Sending "ppp".
    ppp
        PPP: Not enabled
    ascend% 
    --> Hmm... a prompt.  Sending "ppp".
    ppp
        PPP: Not enabled
    ascend% 
    --> Hmm... a prompt.  Sending "ppp".
    Then there's a window saying that it's connected and it starts counting as in a normal connextion but only up to 30 seconds, then it stops. After that, I get the first menu I got when I clicked on the PPP icon on the desktop.

    These are the details produced when it's "connected" for those 30 seconds:

    Code:
    GNOME PPP - DETAILS
    
    Address		Unknown
    Destination	Unknown
    Received	0.0 B
    Sent		0.0 B
    I know the PCMCIA card works fine because I've tried it in Knoppix 3.4 and I had no problems to go on the Internet.

    I hope someone has a clue and can guide me towards the solution. Thank you very much.

    Cheers, xinelo

  2. #2
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    the process of connection is
    1) Modem dials
    2) Internet Service Providers modem answers
    3) Both modems handshake (note :- if you put W2 into the modem initialisation string (ie. before it dials) you will get returned the true connection speed)
    4) Your PC then connects to the Internet Service Providers (ISP) router/gateway (thath's what the userid / password stuff is all about)
    5) Once passed the userid / password tests, your PC should try and start PPP (Point to Point Protocol) between itself and the ISP's router/gateway.

    It is point (5) that is failing. I'm just wondering if you have that PPP will do all of the security checks (some ISPs allow you to use CHAP and/or PAP to do the security checking, and this uses PPP instead of the rather old fashion logging on process). So you may like to play around with that.

    Also, do you get the pppd (PPP daemon) running at all? Try a ps -alx at a terminal.

    good luck, you're almost there

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  3. #3
    Just Joined!
    Join Date
    Jun 2004
    Location
    Galiza
    Posts
    8

    Ignore

    Sorry, bad post. How do i delete it?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jun 2004
    Location
    Galiza
    Posts
    8

    PAP/CHAP & pppd

    Hi Nerderello,

    Thank you so much for your reply. Although the PAP/CHAP bit wasn't very clear to me as what I should do exactly, I least it's suggested me a particular path to follow I apologise as this post might have gotten too long...

    Well, I've been reading "man pppd" and subsequently I've messed with the /etc/ppp/chap-secrets and /etc/ppp/pap-secrets, and this is what they contain (I'm not too sure whether they're ok):

    File: /etc/ppp/chap-secrets (Does the "secret" value = password?)
    Code:
    # Secrets for authentication using CHAP
    # client        server  secret                  IP addresses
    
    ---
    File: /etc/ppp/chap-secrets
    Code:
    # INBOUND connections
    
    # Every regular user can use PPP and has to use passwords from /etc/passwd
    *       hostname        ""      *
    
    # UserIDs that cannot use PPP at all. Check your /etc/passwd and add any
    # other accounts that should not be able to use pppd!
    guest   hostname        "*"     -
    master  hostname        "*"     -
    root    hostname        "*"     -
    support hostname        "*"     -
    stats   hostname        "*"     -
    
    # OUTBOUND connections
    
    # Here you should add your userid password to connect to your providers via
    # PAP. The * means that the password is to be used for ANY host you connect
    # to. Thus you do not have to worry about the foreign machine name. Just
    # PAP. The * means that the password is to be used for ANY host you connect
    # to. Thus you do not have to worry about the foreign machine name. Just
    # replace password with your password.
    # If you have different providers with different passwords then you better
    # remove the following line.
    
    #       *       password
    "telefonicanet@telefonicanet" telefonicanet "telefonicanet"
    
    telefonicanet@telefonicanet * telefonicanet
    As a last desperate option: should I try setting up a /etc/ppp/peers/isp file?

    -----------

    Regarding the second bit...

    I've checked whether pppd runs and I THINK it runs during the 30 seconds that come after the third "Hmm... a prompt. Sending ppp" message. These are the commands I've used (the second example being during it's trying to connect and the third example during those 30 seconds I've mentioned):

    Code:
    xinelo@gnuLinEx:~$ ps -alx | grep pppd
    Warning: bad syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
    0  1000  5314  5148  16   0  2580  756 -      R+   pts/0      0:00 grep pppd
    
    xinelo@gnuLinEx:~$ ps -alx | grep ppp
    Warning: bad syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
    0  1000  5142     1  15   0 17396 11152 -     S    ?          0:01 gnome-ppp
    0  1000  5299     1  16   0 25208 13640 -     S    ?          0:01 gedit file:///wina5/home/ppp.txt
    0  1000  5316  5148  16   0  2580  760 pipe_w S+   pts/0      0:00 grep ppp
    
    xinelo@gnuLinEx:~$ ps -alx | grep ppp
    Warning: bad syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
    0  1000  5142     1  15   0 17512 11168 -     S    ?          0:01 gnome-ppp
    0  1000  5299     1  15   0 25208 13704 -     S    ?          0:02 gedit file:///wina5/home/ppp.txt
    4     0  5513  5420  17   0  2340  984 -      S    ?          0:00 /usr/sbin/pppd 115200 modem crtscts defaultroute usehostname -detach user telefonicanet@telefonicanet noipdefault call wvdial idle 0 logfd 6
    0  1000  5524  5148  15   0  2580  760 pipe_w S+   pts/0      0:00 grep ppp
    I don't know whether it might be relevant or not, but I'll add that I tried from a root session, and the result was (strangely enought to me):

    Code:
    login as root :
    
    
    --> WvDial: Internet dialer version 1.54.0
    --> Initializing modem.
    --> Sending: ATZ M1L3
    ATZ M1L3
    OK
    --> Sending: (null)
    (null)
    --> Sending: ATQ0
    ATQ0
    OK
    --> Re-Sending: (null)
    (null)
    --> Modem not responding.
    I've also checked the firewall and I get a response that I don't understand:

    Code:
    gnuLinEx:/home/xinelo# firestarter
    (firestarter:5613): GnomeUI-WARNING **: While connecting to session manager:
    Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.
    NETFILTER detected
    External network device eth0 is not ready. Aborting..
    I also get a menu message (not on the konsole):

    Code:
    firestarter error:
    The firewall could not start. 
    
    The device eht0 is not ready.
    
    Check configuration of your network device and make sure that your connection to the Internet is available.
    I've also tried some options with the pppd command from the console (such as "pppd noauth" and others) but the result has always been the same.

    Once again, my deepest gratitude to you for your helping me out of the tight spot. Cheers, Manuel

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •