Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
I really have tried to get a stable Linux. It works for *everything* except one problem dogging me for months. Before anyone thinks I am not trying, I have searched, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2009
    Posts
    6

    Linux showstopper (long) Please help.


    I really have tried to get a stable Linux. It works for *everything* except one problem dogging me for months.

    Before anyone thinks I am not trying, I have searched, installed, tweaked, reinstalled on *two* laptops and failed to solve such a basic problem as posting to forums. Again I am using XP to post this!

    I have been having this weird problem "posting" to forums from Ubuntu 8.1, 9.04, NetbookRemix, and now PCLinuxOS.
    Not only on two machines, but with Firefox and Opera as well.

    It seems to be a Linux issue. [Unable to post links until 15 posts - why?]

    To recap From the links I couldn't post: -
    I am in China.
    VIsta and XP have no problems.
    I read that IE is more forgiving on standards such as .php, but I use Firefox and Thunderbird and as much OpenSource software as I can even in windows.
    I cannot post to any forums in Firefox without either a timeout, connection reset, or a request to "open newpost.php" or similar.
    Opera allows posting, but not editing an original new post in Ubuntu.
    In PCLinuxOS, Firefox does nothing, and Opera allowed a "Quote" reply, but not an edit of said reply.
    In Firefox my wife's yahoo web-mail will not "connect through" to the chat client for online contacts from the mailbox page, yet yahoo webmail works.
    In Firefox my wife's yahoo web-mail will not compose new messages or view the preview-pane.
    These last two are not a problem in Opera.

    This problem exists on Ubuntu 8.1, 9.04, 9.04 Netbook remix, and now PCLInuxOS 209.1.

    Unless China is trying, with MS and Google, to cripple any Linux traffic as a business plan, I cannot for the life of me see why I can't just post to newsgroups.

    Firefox failed to post on PcLinuxOS as well.

    I used Opera and managed to post here:

    Yet, on both laptops, Vista and XP allow everything - and I use Firefox and thunderbird on both!

    What is causing the timeouts? What is wrong with Linux/FF/Opera.

    My wife got angry today with the time I have spent on the machines. She likes Linux, but asked why I keep trying to get it working.
    "Because it's better" I said. "No it's not." she replied. "We keep having to use windows."

    Good point, well made.

    I am not an expert, but I am not a novice either. Quite simply, though, I cannot use Linux. It just doesn't work for something I need every day.

    It's crazy, because others report problems and, with no solutions to the search results I have looked at, I wonder if people just gave up?

    The "I've been using xxx for xxx months/years without a problem" replies I sometimes see really do not help.

    I'm prepared to log, look, install. Quite frankly, though, I seem to be flogging a dead horse?

    Is there something going on with China/Linux? The Opera forums are closed by the firewall! (They must be political activists or something )

    Can anyone shine a light? I do want it to work. I dislike Windows for many reasons.

    DavidJ.
    Sorry for the long post, but I have spent many, many hours trying to resolve this and tried various Linux Distros.
    Last edited by DJB1609; 05-16-2009 at 12:46 PM. Reason: More info from links

  2. #2
    Linux User
    Join Date
    May 2009
    Location
    Big River, Sask, Canada
    Posts
    342
    I would like to help you, but it seems to be China-specific. I have never had this problem on any forums, using SUSE, Ubuntu, or Mint with either Firefox or Opera. If my computer wasn't doing background work right now, I could check with AntiX, but the reboot would kill my background work, which is taking forever, and I don't want to start over.
    Registered Linux User #420832

  3. #3
    Just Joined!
    Join Date
    May 2009
    Posts
    6
    Quote Originally Posted by Hal343 View Post
    I would like to help you, but it seems to be China-specific. I have never had this problem on any forums, using SUSE, Ubuntu, or Mint with either Firefox or Opera. If my computer wasn't doing background work right now, I could check with AntiX, but the reboot would kill my background work, which is taking forever, and I don't want to start over.
    Thanks,

    I think it is a Linux/China thing. Or my Linux/Asus W530G V2 Router.

    Why would *only posting* be a problem.

    I mean *everything* else works!!

    DavidJ.

  4. #4
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Posts
    3,858
    West Texas doesn't give me any problems and I don't run Windows. I run Firefox,Epiphany,Sea Monkey,Ice Weasel,Opera. I have ran Midori and Galeon also. No Time outs or problems posting Links as you can see from My signature.

    I Live in the desert. So it aint a Linux thing you are going through. Must be a ISP thing. I've read where China does censor certain things such as newsgroups and such. I agree with Hal that your posting problem seems to be a local problem.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  5. #5
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    That's a weird local problem if it doesn't affect Windows??

    I've had problems in the past posting with a certain browser (Firefox3 when it was still in beta), while other people had no problems. Hmmmm...


    Maybe try this:
    Code:
    firefox 2> ~/firefox-errors
    This starts firefox and logs all the errors into a file called firefox-errors in your home directory. It may give some more info??
    Can't tell an OS by it's GUI

  6. #6
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    China uses linux pretty extensively in internet cafes, doesn't it? I recall reading there was a push by the Chinese government to get cafes to replaces pirated Windows copies with Red Flag Linux. It seems unlikely there is some region specific problem connecting with linux, especially since it's only posting. And it's every forum?

    One difference with linux and windows is that linux has ipv6 enabled by default in most distros. I might try is disabling it. In the Firefox address bar, type about:config, tell it you'll be careful, in the filter bar, type ipv6, you'll see a line network.dns.disableipv6. Double click to change the value from false to true. Disable IPv6 for Firefox - openSUSE

    You can also disable the ipv6 protocol system wide by blacklistnig the module. I'm not sure of the location with pclinuxos, but usually the list is at /etc/modprobe.d/blacklist, and you just add a line reading
    Code:
    blacklist ipv6
    and I sometimes add
    Code:
    install ipv6 /bin/true
    Just to ensure that if something does try and load the module, it's sent off into the void.

  7. #7
    Just Joined!
    Join Date
    May 2009
    Posts
    6
    Blocking IPv6 doesn't change things. Thank you for the suggestion.

    Although it works in windows, and I can surf etc. in Ubuntu, does it matter if my wireless and ADSL modem have the same IP - 192.168.1.1?

    Could that be an issue?

    My Asus W530G V2 is the wireless, and I can access it at 192.168.1.1. I set it up as ppoE with the password etc. given by the ISP.

    The Modem is a Chinese language ZTE XDSL 831, set up by the Chinese ISP. It has the same IP address, and I have to disconnect the Asus and go wired to access it's homepage - which is all Chinese!

    If I have to change anything, it would have to be the Asus.

    I know others can post from Linux in China from another forum.

    Thanks, as any help is appreciated. (I don't want to give up!)

    DavidJ.

  8. #8
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Have you tried any other browsers besides Firefox and Opera? Epiphany, Midori, Arora, and Kazehakase, are some alternatives. You could see if you get the same troubles with those.

    Unless you're saying you have two simultaneous connections using the same IP address, that isn't an issue.

  9. #9
    Just Joined!
    Join Date
    May 2009
    Posts
    6
    I will look into other browsers, but I am thinking it is a router/local network problem. I have two laptops sharing one Wireless router>Adsl modem.

    When I had a D-Link wireless with an IP 192.168.0.1, I had no problem.

    I first suspected it was an Ubuntu problem with changed hardware, and my thinking was vertical from there as Windows on both machines worked. I kept looking at it as a Linux problem.

    Rethinking: I moved house, got a new (Chinese) modem *and* a new router because the D-Link failed to connect.

    I am suspecting the Chinese modema and will try a friends D-Link ADSL+ modem later, as I know it has a different IP address.

    I seem to recall Vista throwing me "IP conflict" messages, but for some reason everything worked and they are rare.

    Again, I thank everyone for their assistance with my ignorance. One of the strengths of Linux is the community support and I am very grateful.

    DavidJ.

  10. #10
    Just Joined!
    Join Date
    May 2009
    Posts
    6
    This is a test post: Test.

    Test Edit: Second Edit.
    Last edited by DJB1609; 05-22-2009 at 10:58 AM. Reason: Testing Editing Again.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •