Find the answer to your Linux question:
Results 1 to 5 of 5
Stuck with Linux wireless networking. Working with ubuntu. I can get wireless working if I run the following commands: ifconfig wlan0 down ifconfig wlan0 192.168.1.244 netmask 255.255.255.0 up route add ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2009
    Posts
    9

    Linux wireless


    Stuck with Linux wireless networking. Working with ubuntu.

    I can get wireless working if I run the following commands:

    ifconfig wlan0 down
    ifconfig wlan0 192.168.1.244 netmask 255.255.255.0 up
    route add default gw 192.168.1.1
    iwconfig wlan0 essid "linksys"
    iwconfig wlan0 mode Managed
    dhclient wlan0

    This works and everything is fine. But I don't want to run this script everytime.

    I thought I should configure etc/network/interfaces here is my file:
    auto lo
    iface lo inet loopback

    auto wlan0
    iface wlan0 inet static
    wireless-essid linksys
    address 192.168.1.222
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.1.255
    gateway 192.168.1.1

    iface eth0 inet dhcp

    auto eth0


    After reboot, I can ping 192.168.1.222 and ping 127.0.0.1 but not my router.

    Any ideas on what I am screwing up?

    Bill

  2. #2
    Just Joined!
    Join Date
    May 2009
    Posts
    9
    Just realized that there is also a wireless forum.

    I will move my question over there.

    Sorry,

    Bill

  3. #3
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,691
    If you want it to start up and connect before you login, then add your script to /etc/rc.d/rc.local
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    May 2009
    Posts
    9
    Quote Originally Posted by Rubberman View Post
    If you want it to start up and connect before you login, then add your script to /etc/rc.d/rc.local
    Yeah, I thought about doing that but it bugs me that it doesn't just work when I am putting, what I think, is the correct settings.

    I need more time to play with things.

    Thanks!

    Bill

  6. #5
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,691
    One of the reasons why wireless isn't enabled on bootup, but only at user login time once the desktop manager is active, is because most wireless connections require a passphrase to connect, and that is normally stored in the users' key repository, which requires user input to unlock. Wired ethernet isn't so encumbered, so it can be initialized and active before the boot process finishes. Hence the extra effort you need to apply to get wireless initialized and connected during the boot process.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •