Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I'm posting this msg here because i searched lots of forum without finding any answers. I have a serveur working on gentoo, and a debian client. On the server: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2009
    Posts
    2

    snmpd listening only on localhost


    Hi,
    I'm posting this msg here because i searched lots of forum without finding any answers.

    I have a serveur working on gentoo, and a debian client.

    On the server:
    -I configure snmpd.conf correctly.
    -I request the localhost MIB successfully with snmpwalk
    -There is no IPTables

    On the client:
    -I configure snmpd.conf to allow remote access from my gentoo server.
    -I open the 161 ports on the IPTABLES.
    -I request the localhost MIB successfully with snmpwalk
    -I remove the 127.0.0.1 in the line : SNMPDOPTS='-Lsd -Lf /dev/null -u snmp -I -smux -p /var/run/snmpd.pid 127.0.0.1'
    I even tried to comment this line.


    the pb is that my server never manage to access the client MIB.
    The answer of an snmpwalk result: "Timeout: No Response from "

    I don't have a file like /etc/default/snmpd on the server (gentoo install different from debian install ?)
    So I don't know what's my pb...
    Perhaps someone can help me?

  2. #2
    Just Joined!
    Join Date
    May 2009
    Posts
    2
    If that can help, here is my /etc/snmp/snmpd.conf file on the client

    Code:
    #####snmpd conf file
    
    com2sec local     127.0.0.1    public
    com2sec local     MyServerAddress   public
    
    group MyROGroup v1         local
    group MyROGroup v2c        local
    group MyROGroup usm        local
    
    view all    included  .1                               80
    
    access MyROGroup ""      any       noauth    exact  all    none   none
    And here is my /etc/default/snmpd

    Code:
    # This file controls the activity of snmpd and snmptrapd
    
    # MIB directories.  /usr/share/snmp/mibs is the default, but
    # including it here avoids some strange problems.
    export MIBDIRS=/usr/share/snmp/mibs
    
    # snmpd control (yes means start daemon).
    SNMPDRUN=yes
    
    # snmpd options (use syslog, close stdin/out/err).
    SNMPDOPTS='-Lsd -Lf /dev/null -u snmp -I -smux -p /var/run/snmpd.pid '
    
    # snmptrapd control (yes means start daemon).  As of net-snmp version
    # 5.0, master agentx support must be enabled in snmpd before snmptrapd
    # can be run.  See snmpd.conf(5) for how to do this.
    TRAPDRUN=no
    
    # snmptrapd options (use syslog).
    TRAPDOPTS='-Lsd -p /var/run/snmptrapd.pid'
    
    # create symlink on Debian legacy location to official RFC path
    SNMPDCOMPAT=yes
    ~

  3. #3
    Just Joined!
    Join Date
    Mar 2010
    Posts
    2

    Reg SNMP server

    Please tell me how you configured the NET-SNMP in the machine so that we can use snmpwalk command on that machine..
    Thanks in advance

  4. #4
    Just Joined!
    Join Date
    Mar 2010
    Posts
    2
    Quote Originally Posted by nk2a View Post
    Hi,
    I'm posting this msg here because i searched lots of forum without finding any answers.

    I have a serveur working on gentoo, and a debian client.

    On the server:
    -I configure snmpd.conf correctly.
    -I request the localhost MIB successfully with snmpwalk
    -There is no IPTables

    On the client:
    -I configure snmpd.conf to allow remote access from my gentoo server.
    -I open the 161 ports on the IPTABLES.
    -I request the localhost MIB successfully with snmpwalk
    -I remove the 127.0.0.1 in the line : SNMPDOPTS='-Lsd -Lf /dev/null -u snmp -I -smux -p /var/run/snmpd.pid 127.0.0.1'
    I even tried to comment this line.


    the pb is that my server never manage to access the client MIB.
    The answer of an snmpwalk result: "Timeout: No Response from "

    I don't have a file like /etc/default/snmpd on the server (gentoo install different from debian install ?)
    So I don't know what's my pb...
    Perhaps someone can help me?

    Please tell me how you did this:
    On the server:
    -I configure snmpd.conf correctly.
    -I request the localhost MIB successfully with snmpwalk

    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •