Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 14 of 14
Jumbo frames (not standard - don't always work) will greatly reduce the number of packets, hence the greater thruput. I don't know if you can enable them on your Linux ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,449

    Jumbo frames (not standard - don't always work) will greatly reduce the number of packets, hence the greater thruput. I don't know if you can enable them on your Linux system or not - I haven't tried it myself. However, I have a couple of NAS appliances that have an embedded Linux running them that does support jumbo frames, so in theory it is possible.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  2. #12
    Linux Newbie Mad Professor's Avatar
    Join Date
    May 2006
    Posts
    142
    I think my backup server is the problem it can receive 60% throughput but sending out is about 30%

    Everything seems to be working now after I modify the sysctl.conf and enable jumbo frames and use 64K window sizes.

    Definitely need to keep tweaking it.

    Any suggestions?

  3. #13
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,449
    Well, it sounds like you are doing the right things. I'm out of further ideas at the moment. Default speeds for gigabit connections have been adequate for my needs up to this point. I'd love to here what you find that works to maximize your thruput though, for future reference.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  4. #14
    Linux Engineer b2bwild's Avatar
    Join Date
    Jul 2008
    Location
    Behind You!
    Posts
    1,108
    Quote Originally Posted by Mad Professor View Post
    I think my backup server is the problem it can receive 60% throughput but sending out is about 30%

    Everything seems to be working now after I modify the sysctl.conf and enable jumbo frames and use 64K window sizes.

    Definitely need to keep tweaking it.

    Any suggestions?
    Well, at least you now have better results.
    there are always bit limitations, I have not seen anyone with more than 850-900Mbit throughput on Gbit network.. for that you need some more firepower on your machine.

    remember that every testing tool also have limitations.
    Never make any misteaks.

    Read my Blog at --> Penguin Inside Subscribe Feed

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •