Find the answer to your Linux question:
Results 1 to 4 of 4
Damn! I was reading and using Gentoo. I unplugged my cable modem. I plugged it back in. Nothing! I rebooted, nothing. I shutdown, nothing. I unplugged and plugged it back ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! chigurh's Avatar
    Join Date
    Jul 2009
    Posts
    24

    Unhappy /etc/hosts ::1


    Damn!
    I was reading and using Gentoo. I unplugged my cable modem. I plugged it back in. Nothing! I rebooted, nothing. I shutdown, nothing. I unplugged and plugged it back in again. Nothing. I couldn't open any sites. The connection wouldn't complete.
    I didn't know what to do. The first thing I thought of was /etc/hosts. I opened it up, removed the line that has ::1 localhost
    which is (::1 gentoo) on mine
    It instantly worked. I didn't know, but I knew everything was working perfectly. What is the problem? Can not having this line cause problems? I read it's IPv6, but I didn't find anything good to read about it.
    Anyways, now it's working fine again. I hope I did correct this problem. If so, it was definitely easy to guess.

  2. #2
    Linux Engineer b2bwild's Avatar
    Join Date
    Jul 2008
    Location
    Behind You!
    Posts
    1,108
    It should not cause any problem..
    One way to figure out...try putting it back and check if there are any problems.
    It seems more like co-incidence for me.
    Never make any misteaks.

    Read my Blog at --> Penguin Inside Subscribe Feed

  3. #3
    Just Joined! chigurh's Avatar
    Join Date
    Jul 2009
    Posts
    24
    No, it's still happening. I put it back in the file, and my connection quit working. I deleted it again, and it connected.
    I fixed it all by myself.

  4. #4
    Just Joined! chigurh's Avatar
    Join Date
    Jul 2009
    Posts
    24
    It was on the second line, but both times it would not work until I deleted it and then it would instantly work. I never used IPv6 USE flags or anything, if you were wondering ...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •