Find the answer to your Linux question:
Results 1 to 5 of 5
Hi, Im using Red Hat 9 and i want to set up ssh. So i looked it up on the Red Hat website and entered the following command(after checking the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Posts
    6

    ssh wont accept connections?


    Hi,

    Im using Red Hat 9 and i want to set up ssh. So i looked it up on the Red Hat website and entered the following command(after checking the config file, witch looked OK(just default)):

    Code:
    /sbin/service sshd start
    it gives back :

    Code:
    Starting sshd:                                  [ OK ]
    after that i checked the service file in /etc/service to see if the port was open, it was. now i tried connecting to it with another computer with PUTTY, but it just times out. Connecting to localhost on port 22 with the SSH command gave back the following:

    Code:
     The authenticity of host '127.0.0.1 (127.0.0.1)' can't be established. RSA key fingerprint **.**.**(etc).
    Are you sure you want to continue connecting(yes/no)?
    i typed yes and after that i could connect, but it said:

    Code:
    Warning, permantly added '127.0.0.1' (RSA) to the list of known hosts.
    when i connected a second time the warning was gone(becouse its added temporary i guess).

    Does anyone know how to fix this problem?

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    The fact that it didn't warn you the second time is normal, because you have told it that you trust the identity of 127.0.0.1
    As for the matter of trying to ssh into your box remotely, do you have any firewalls (i.e. ipchains or iptables) up on your box?

  3. #3
    Just Joined!
    Join Date
    Oct 2004
    Posts
    6
    Ye i thought so myself.

    And as of the ipchains and firewalls, not that im aware off, as its being used intern and is still a testserver. I also have an Apache server running and this works fine, i also have Nagios running, and these connections also work fine. I scanned my box with GFI languard and it only gave port 80 as an open port, witch is strange. I also checked the running processes and sshd is marked as running.

    When i connect it just gives a connection timeout.

    Anyway i can test if theres a firewall active that blocks it? (sorry for my n00bishness, but i only use linux for 3 weeks now)


    *edit*edit*edit**edit*edit*edit**edit*edit*edit**e dit*edit*edit*

    I checked the /etc/sysconfig/iptables file, and it says:

    -A RH-Lokkit-0-50-INPUT -p tcp --dport 0:1023 --syn -j REJECT

    i think thats why its not working, tho it also states that it doesnt recomend manual editing of the file. Anyone got any suggestions?

    I also checked the host.allow and host.deny files, and there both empty(appart from the comments). Im not sure if thats a good thing tho

  4. #4
    Just Joined!
    Join Date
    Oct 2004
    Posts
    6
    Alright. I ran lokkit from the terminal and i tried opening port 22, it works perfectly now. Tnx for the help lakerdonald

  5. #5
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    no problem. glad that worked out for you

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •