Find the answer to your Linux question:
Results 1 to 2 of 2
Edit: Nevermind.. I am past this step, now tftpboot can't find the files lol. The error was I specified the wrong range for dynamic-bootp. Hey guys, Trying to install slackware ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2006
    Location
    San Jose, CA
    Posts
    67

    DHCPD and PXE Server


    Edit: Nevermind.. I am past this step, now tftpboot can't find the files lol. The error was I specified the wrong range for dynamic-bootp.

    Hey guys,

    Trying to install slackware on a laptop through a PXE server. I think I have most of the stuff right except the dhcpd.conf settings, which seem to be a bit off. I not very good with networking so would really appreciate if someone can take a look and point out what I have wrong .

    I have got 2 pc's connected via a router(192.1681.1), and one of them is running the PXE Server (192.168.1.145). I get this error from dhcpd
    Code:
    slackhost dhcpd: bad range, address 192.168.1.140 not in subnet 192.168.0.0 netmask 255.255.255.0
    Another bit I am unsure about is "option domain-name".. I don't have a domain setup on my internal network, so can this be blank or do I need to specify a domain?
    Code:
    # dhcpd.conf
    #
    # Configuration file for ISC dhcpd (see 'man dhcpd.conf')
    #
    # dhcpd.conf
    #
    # Configuration file for ISC dhcpd
    #
    
    # If this DHCP server is the official DHCP server for the local
    # network, the authoritative directive should be uncommented.
    authoritative;
    ddns-update-style none;
    
    # Allow bootp requests
    allow bootp;
    
    # Point to the TFTP server:
    next-server 192.168.1.145;
    
    # Default lease is 1 week (604800 sec.)
    default-lease-time 604800;
    # Max lease is 4 weeks (2419200 sec.)
    max-lease-time 2419200;
    
    subnet 192.168.1.0 netmask 255.255.255.0 {
        option domain-name "";
        option broadcast-address 192.168.1.255;
        option subnet-mask 255.255.255.0;
        option domain-name-servers 192.168.1.1;
        option routers 192.168.1.1;
        range dynamic-bootp 192.168.1.140 192.168.1.150;
        use-host-decl-names on;
        if substring (option vendor-class-identifier, 0, 9) = "PXEClient" {
          filename "/tftpboot/slackware-12.2/pxelinux.0";
        }
    }

  2. #2
    Just Joined!
    Join Date
    May 2006
    Location
    San Jose, CA
    Posts
    67
    So I figured out my PXE Server and have successfully installed Slackware64 current on my laptop. One minor thing that I overlooked was that you don't specify the root directory of tftpboot in the filename path. You specify that elsewhere, so simply my dhcpd.conf file needed to look like this

    Code:
     filename "slackware-12.2/pxelinux.0";
    Hope this helps out anyone else who might be trying to setup a PXE server .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •