Find the answer to your Linux question:
Results 1 to 8 of 8
hi, i am runing fc2,there was problem with ppp to come up,i unchecked the lock file and changed the termination line from CR/LF to just CR,now kppp can connect to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Posts
    28

    cannot browse any web site in fc2


    hi,
    i am runing fc2,there was problem with ppp to come up,i unchecked the lock file and changed the termination line from CR/LF to just CR,now kppp can connect to the isp but the problem is,i cannot connect to the internet,i can't browse any internet sites as there is no connection at all,the defualt firewall for the fc2 was enabled so i desabled it and reboot the pc but still i can't connect to the internet,i tried the netscape,firefox and gaim,i don't kwnow if there is any other firewall in fc2 packages that is blocking the internet because i intalled all the packages, this is the /var/log/messages:
    Oct 17 21:44:41 localhost kernel: PPP generic driver version 2.4.2
    Oct 17 21:44:41 localhost pppd[2744]: pppd 2.4.2 started by root, uid 0
    Oct 17 21:44:41 localhost pppd[2744]: Using interface ppp0
    Oct 17 21:44:41 localhost pppd[2744]: Connect: ppp0 <--> /dev/ttySHSF0
    Oct 17 21:44:43 localhost pppd[2744]: PAP authentication succeeded
    Oct 17 21:44:43 localhost kernel: PPP Deflate Compression module registered
    Oct 17 21:44:43 localhost pppd[2744]: local IP address (removed)
    Oct 17 21:44:43 localhost pppd[2744]: remote IP address (removed)
    Oct 17 21:44:43 localhost pppd[2744]: primary DNS address (removed)
    Oct 17 21:44:43 localhost pppd[2744]: secondary DNS address (removed)
    Oct 17 21:47:04 localhost pppd[2744]: Terminating on signal 15.
    Oct 17 21:47:05 localhost pppd[2744]: Connection terminated.
    Oct 17 21:47:05 localhost pppd[2744]: Connect time 2.4 minutes.
    Oct 17 21:47:05 localhost pppd[2744]: Sent 142 bytes, received 136 bytes.
    Oct 17 21:47:07 localhost pppd[2744]: Connect time 2.4 minutes.
    Oct 17 21:47:07 localhost pppd[2744]: Sent 142 bytes, received 136 bytes.
    Oct 17 21:47:07 localhost pppd[2744]: Exit.
    plz help me.

  2. #2
    Linux Newbie
    Join Date
    Jan 2004
    Location
    Belgrade, S&M
    Posts
    177
    Just before accessing the internet disable all firewalls:
    Code:
    iptables -F
    iptables -X
    iptables -P INPUT ACCEPT
    iptables -P OUTPUT ACCEPT
    Then try entering this in the browser address box : 216.109.112.135 (that should open yahoo's error page). Thus you bypassed your firewall and DNS, so if this doesn't work.. I don't know. After connecting try to run ifconfig. Do you see a ppp interface ? try pinging your ISP or something. If that doesn't work too than try running route. Then you can add routes to your ISP. Good luck !

  3. #3
    Just Joined!
    Join Date
    Oct 2004
    Posts
    28

    thnks for reply

    hi,
    i can browse now the websites with thier ip addresses but can' t browse with thier hosnames,i use internet cards with dynamic ip,,i use as well as mandrake 10 and no problem wiht it but the problem is with fc2 i just installed.

  4. #4
    Linux Newbie
    Join Date
    Jan 2004
    Location
    Belgrade, S&M
    Posts
    177
    Hi, if that is the case then there is a problem with your DNS: configuration in Mandrake (maybe you made a mistake while typing):

    1) either the DNS is not set (add it to your /etc/resolv.conf)
    2) or you specified a false IP address for a DNS server (again, add the real ip to add it to your /etc/resolv.conf)

    I hope that helps.

  5. #5
    Just Joined!
    Join Date
    Oct 2004
    Posts
    28

    i add the remote ip from /var/log/messages

    h,
    i add the remote ip from /var/log/messages to the /etc/resolv.conf,but still the same problem exitsts,i am using as well as mandrake 10 in the same pc with the fc2, with the same modem and kppp settings but no problem with it at all it can update the nameservers from the isp sucessfully,with each connection the problem is with fc2 i just insalled i am using internet cards with conexant hsf modem and kppp for internet connecion.

  6. #6
    Linux Newbie
    Join Date
    Jan 2004
    Location
    Belgrade, S&M
    Posts
    177
    Hi. Well, if f you are sure that your DNS settings are ok (my Slackware doesn't detect the nameservers automativally) then try connecting using pppsetup and ppp-go (if they exist in fc2). I recall having some trouble with KPPP back in Slack 9 when I could access only a limited number of sites ...

  7. #7
    Just Joined!
    Join Date
    Oct 2004
    Posts
    28
    hi,
    if you can please explain little more pppsetup and ppp.go?

  8. #8
    Linux Newbie
    Join Date
    Jan 2004
    Location
    Belgrade, S&M
    Posts
    177
    Try typing pppsetup in the console as root. I am not sure if FC2 has that command. If there is it will ask you for settings about your ISP (and other things, modem port,user name, pass). Once you enter the correct settings try typing ppp-go or ppp-on to connect to the internet.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •