Find the answer to your Linux question:
Results 1 to 2 of 2
I am relatively new to linux. I have setup a Samba share and it works until I reboot. I have Ubuntu 9.04 server with a static IP address. Currently, it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2009
    Posts
    2

    Question Samba share fails after restart


    I am relatively new to linux. I have setup a Samba share and it works until I reboot.

    I have Ubuntu 9.04 server with a static IP address.

    Currently, it works if I run the following:

    # smbpasswd gillani

    then enter the password

    but as soon as I reboot, I get prompted at the share (in XP and Vista) for a user id and password. If I enter the password it still doesn't work.

    As soon as re-run smbpasswd, it works again.



    SMB.conf

    [global]
    ; General server settings
    netbios name = linux
    server string =
    workgroup = gillani
    announce version = 5.0
    socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE SO_RCVBUF=8192 SO_SNDBUF=8192
    passdb backend = tdbsam
    security = user
    null passwords = true
    username map = /etc/samba/smbusers
    name resolve order = hosts wins bcast

    wins support = yes

    syslog = 1
    syslog only = yes

    [LinuxShare]
    path = /home/shares/allusers
    browseable = yes
    read only = no
    guest ok = no
    create mask = 0644
    directory mask = 0755
    force user = gillani
    force group = gillani


    Any help is welcome.. thanks

  2. #2
    Just Joined! chris81's Avatar
    Join Date
    Jan 2009
    Posts
    62
    Hi

    Quote Originally Posted by gillani View Post
    but as soon as I reboot, I get prompted at the share (in XP and Vista) for a user id and password. If I enter the password it still doesn't work.

    As soon as re-run smbpasswd, it works again.

    SMB.conf

    [global]
    ; General server settings
    netbios name = linux
    server string =
    workgroup = gillani
    announce version = 5.0
    socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE SO_RCVBUF=8192 SO_SNDBUF=8192
    passdb backend = tdbsam
    security = user
    null passwords = true
    username map = /etc/samba/smbusers
    name resolve order = hosts wins bcast

    wins support = yes

    syslog = 1
    syslog only = yes

    [LinuxShare]
    path = /home/shares/allusers
    browseable = yes
    read only = no
    guest ok = no
    create mask = 0644
    directory mask = 0755
    force user = gillani
    force group = gillani



    Any help is welcome.. thanks
    I think that you can just set guest ok = yes instead of no or you can set force user = desired name or if you want an entire group, then set force group = group name

    but before, i suggest you to check if there's some mapping in the /etc/samba/smbusers. If so, then you might have to add some mapping into that file and then use those mapping instead of real names in the previous paragraph (force user=mapped user, force group = mapped group).

    Hope it helped
    chris81

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •