Find the answer to your Linux question:
Results 1 to 6 of 6
I'm new to apache, this is the first web server I've attempted to configure and I just can't seem to get it visible. Yes, apache IS running. I know apache ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2009
    Posts
    3

    Port forwarding - apache server not visible from public side


    I'm new to apache, this is the first web server I've attempted to configure and I just can't seem to get it visible. Yes, apache IS running. I know apache is running correctly (I can view the test html files on the private side), I can view files like 192.168.1.250:8080/test.html. My apache/conf/httpd.conf includes:

    Listen 8080
    ServerName 192.168.1.250:8080

    which are the only 2 lines I edited I believe, besides AddType for php.

    Having gone over lots of apache config walkthroughs and such, I thought my router was to blame (verizon blocks port 80 requests apparently?). My router is a Verizon Fios ActionTec M1424WR. The port forwarding rule is setup as:
    Networked Computer / Device: 192.168.1.250
    Network Address: 192.168.1.250:8080
    Public IP Address:
    Remote Host IP Address:
    Protocols: HTTP - TCP Any -> 80
    WAN Connection Type: All Broadband Devices
    Status: Active

    But trying to load my public IP with :8080 just loads my router's config page. When I had the port changed to something else earlier (8095), it would just be not found.

    Im using Slackware 12 with apache 2.2, php 5.2, mysql 5.1. I hope this is something obvious and im just a noob

  2. #2
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    is your router already listening on port 8080?

    I've never used a verizon router, but typically all port forwarding entails is using the router GUI and telling it to forward the specified port using the specified protocol (TCP in your case) to the internal IP address

  3. #3
    Just Joined!
    Join Date
    Oct 2009
    Posts
    3
    Yes, it is. I actually mistyped that rule above, its listening on HTTP Secondary (8080), not 80.

  4. #4
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    if your router is listening on 8080 then i'm guessing that is the problem, change your apache port to something else

  5. #5
    Just Joined!
    Join Date
    Oct 2009
    Posts
    3
    Ive tried setting it 8095. My apache conf has "Listen 8095", and "ServerName 192.168.1.250:8095". I feel like I've tried every combination of setting with this router to the point that there is something very basic I'm missing - is there anyway you could list me the basic requirements you can think of to set something like this up?

  6. #6
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    these are some of the most basic functionality a router will provide

    Determine local IP
    Determine local port
    tell router firewall to not block local port
    tell router to forward requests on local port to local ip
    Possibly restart router after applying changes

    If this is not working, there are a few possibilities:
    You did it wrong, recheck your steps.
    Your ISP simply does not allow you to do this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •