Find the answer to your Linux question:
Results 1 to 2 of 2
It's the damnedest thing... this computer/cable modem combo's been working just fine for years. All of a sudden, a few months ago, sometimes the computer recognizes the cable modem, sometimes ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2008
    Posts
    4

    Cable Modem/Realtek driver flakiness


    It's the damnedest thing... this computer/cable modem combo's been working just fine for years. All of a sudden, a few months ago, sometimes the computer recognizes the cable modem, sometimes it doesn't. Everything else is just fine.

    If it boots up and says "eth0: link down", I just Ctrl+C out of dhclient (since it will sit there for several minutes trying to obtain an IP address if I don't), and then go through a series of:

    rmmod r8169
    modprobe r8169

    If I do this over and over, eventually it recognizes the link and connects, and I can run dhclient and obtain an IP address. I can watch the 'link" light on the Motorola Surfboard SBV5220 and watch the link light go on and off (strangely, it usually lights up when I run rmmod, and then off when I run modprobe again the first few times).

    Has anybody else ever seen anything like this? I've had the cable modem people out a couple of times and of course they said everything was just fine (although they finally replaced the cable modem just to shut me up). I can't help but suspect the cable anyway, but I wondered if somebody out there knew about something I didn't (sure wouldn't be the first time...)

  2. #2
    Just Joined!
    Join Date
    Nov 2009
    Posts
    1

    Look at watches.

    Look at watches. Look at watches.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •