Find the answer to your Linux question:
Results 1 to 3 of 3
Dear all experts, I am now facing a problem with my web server. I have no problem connecting to my website within the company network but once I try to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Posts
    1

    Fail to reach Host


    Dear all experts,

    I am now facing a problem with my web server. I have no problem connecting to my website within the company network but once I try to connect from outside, it will say "The requested URL could not be retrieved". But I have no problems with PING from inside and outside the network.

    I have looked thru the forum and some of them is also facing this problem. I tried their methods and it still doesn't work. And also I have just configured the following, but still it doesn't work either.

    <Directory "/var/www/html">
    Options Indexes Includes FollowSymLinks
    Order deny,allow
    AllowOverride None
    Allow from all
    </Directory>

    My firewall is currently enabled, and WWW (http) is my trusted services, eth0 is my trusted device. As for iptables, I Accept connections coming for port 80.

    No luck too when I turned off the firewall and iptables.

    This is my site.. http://enterprise.ise.nus.edu.sg

    I got a friend to do a tracert for me and this is the results. (but i don't if this can contribute to solving the problem)

    At #15, it manages to reach nusnet-3-193.dynip.nus.edu.sg but after it got timeout . What does this mean?
    -------------------------------------------------------------------------------------
    1 2 ms 2 ms 1 ms host-203-92-100-167.lga.net.sg [x.x.x.x]

    2 16 ms 16 ms 16 ms host-203-92-91-53.lga.net.sg [x.x.x.x]

    3 21 ms 21 ms 19 ms host-203-92-90-226.lga.net.sg [x.x.x.x]

    4 22 ms 20 ms 19 ms host-203-92-84-25.lga.net.sg [x.x.x.x]

    5 19 ms 32 ms 24 ms host-203-92-84-18.lga.net.sg [x.x.x.x]

    6 41 ms 229 ms 189 ms 61.8.233.173

    7 22 ms 26 ms 25 ms ge-1-0-0.r00.sngpsi01.sg.bb.verio.net [x.x.x.x]

    8 206 ms 187 ms 190 ms p1-0-1-2.r80.sttlwa01.us.bb.verio.net [x.x.x.x]

    9 195 ms 204 ms 227 ms p16-1-1-1.r21.sttlwa01.us.bb.verio.net [x.x.x.x]

    10 212 ms 195 ms 187 ms p16-2-0-0.r03.sttlwa01.us.bb.verio.net [x.x.x.x]

    11 228 ms 224 ms 210 ms p1-0.usngp.sttlwa01.us.bb.verio.net [x.x.x.x]

    12 178 ms 186 ms 186 ms pos1-0.pgp-cr1.singaren.net.sg [x.x.x.x]

    13 192 ms 197 ms 194 ms ge3-9.pgp-dr1.singaren.net.sg [x.x.x.x]

    14 204 ms 289 ms 258 ms nus-pgp-border.singaren.net.sg [x.x.x.x]

    15 188 ms 186 ms 190 ms nusnet-3-193.dynip.nus.edu.sg [x.x.x.x]

    16 * * * Request timed out.

    17 * * * Request timed out.

    18 * * * Request timed out.

    19 182 ms 188 ms 190 ms enterprise.ise.nus.edu.sg [x.x.x.x]


  2. #2
    Just Joined!
    Join Date
    Apr 2004
    Location
    UK
    Posts
    61
    From an external system try to telnet port 80 on your machine and make sure that a connection can actually be made to your system.

    On that connection try typing the following and see if data can be retrieved from the system. ([hostname goes here] should not be typed but replaced with the appropriate hostname and where it says [enter] press the enter key again so the server knows you have finished input.

    Code:
    GET / HTTP/1.1
    HOST&#58;&#91;hostname goes here&#93;
    &#91;enter&#93;
    You should end up with something like this

    Code:
    &#91;sarah@warp sarah&#93;$ telnet &#91;HOSTNAME&#93; 80
    Trying &#91;HOST&#93;...
    Connected to &#91;HOST&#93;.
    Escape character is '^&#93;'.
    GET / HTTP/1.1
    HOST&#58;&#91;HOSTNAME&#93;
    
    HTTP/1.1 200 OK
    Date&#58; Sat, 23 Oct 2004 00&#58;12&#58;54 GMT
    Server&#58; Apache/2.0.52 &#40;Debian GNU/Linux&#41; PHP/4.3.9-1
    Last-Modified&#58; Thu, 07 Oct 2004 10&#58;25&#58;13 GMT
    ETag&#58; "2401a-41-e8e2b440"
    Accept-Ranges&#58; bytes
    Content-Length&#58; 65
    Content-Type&#58; text/html; charset=ISO-8859-1
    
    <HTML>
    <HEAD>
    </HEAD>
    <BODY>
    Nothing to see here
    </BODY>
    </HTML>
    Connection closed by foreign host.
    &#91;sarah@warp sarah&#93;$
    If you are unable to connect in the first instance then there is an issue with an upstream system blocking access (assuming your firewall is configured correctly or disabled)

    If you connect fine but get an error then act on that error. It may be that you need to set up apache differently, eg tell it to listen on the external interface or set up a virtual host for the hostname you are using.

  3. #3
    Linux Newbie
    Join Date
    Jan 2004
    Location
    Belgrade, S&M
    Posts
    177
    Are you using a dynamic IP (nusnet-3-193.dynip.nus.edu.sg ???) ? Is the hostname pointing to the right IP ?

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •