Find the answer to your Linux question:
Results 1 to 2 of 2
I am using a ppp network to communicate across two transceivers. The transceivers act like a serial cable directly connecting two computers. I am running a pppd getty in /etc/inittab ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2009
    Posts
    2

    How to disable INIT: respawning to fast disabling for 5 minutes"


    I am using a ppp network to communicate across two transceivers. The transceivers act like a serial cable directly connecting two computers.

    I am running a pppd getty in /etc/inittab

    Code:
    pd:2345:respawn:/usr/sbin/pppd /dev/ttyUSB0 nodetach
    Well occasionally I will get a hiccup in the connection and I will lose the ability to use the PPP network because it has been disabled for 5 minutes as shown below:

    Code:
    INIT: Id "pd" respawning too fast: disabled for 5 minutes
    and then shortly after it will respawn fine:

    Code:
    Connect: ppp0 <--> /dev/ttyUSB0
    I am wonder how I can either disable INIT from disabling it, or shorten the time that it is disabled. Either that or I want to find a way to figure out exactly what is causing it.

    Other than this the connection is fairly stable and has no problems. Any help would be appreciated

  2. #2
    Just Joined!
    Join Date
    Jun 2008
    Posts
    7

    Add pppd delay or else recompile init

    I don't have much experience with this but perhaps add the "connect" flag to the pppd line and run something that times out for a few seconds before each new start of pppd. Perhaps pppd gets knocked by noise and tries to start up too fast or before the other end has cleaned up (I'm guessing).

    >> pd:2345:respawn:/usr/sbin/pppd /dev/ttyUSB0 nodetach connect 'sleep 5'

    Changing to this line above might cause pppd to respawn no faster than every 5 seconds, and that might solve the problem.

    If you want to take chances, you can also try to recompile init (eg, maybe you use the "sysinit" project at freshmeat) and change "#define SLEEPTIME 300 /* Disable time */" to a value less than 300 (300 is 5 minutes).

    Sorry, but I have not tested these suggestions and am working off limited amount of knowledge and experience.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •