Find the answer to your Linux question:
Results 1 to 4 of 4
Hello all I have added new samba shares to a samba server where the existing shares and permissions work as they should be. However when adding a new share my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    tqz
    tqz is offline
    Just Joined!
    Join Date
    Jan 2008
    Posts
    50

    samba shares


    Hello all

    I have added new samba shares to a samba server where the existing shares and permissions work as they should be.

    However when adding a new share my permissions dont work exactly how I would like them too and not 100% sure why!
    This is how I go about creating my share:-

    1) Create the share directory in webmin
    2) Edit the samba file with something like

    [Test]
    browseable = Yes
    writeable = yes
    path = /home/Test
    create mask = 0770
    directory mask = 0770
    valid users = @"ABC\group"
    public = yes
    inherit acls = yes

    3) change group ownership of the dir to ABC\group.

    So only the users in the ABC\group group have access to the share (as required). They can read a file, create files, modify contents of a file, and delete directories from the Test dir. However loose files not within dir cannot be deleted and nor can a file be renamed.

    Any ideas???

    Thanks in advance for any help!

    t.

  2. #2
    Just Joined!
    Join Date
    Jan 2008
    Posts
    28
    My Samba servers are rather old, so there might be newer information... And, I don't use Webmin...

    First, you need to make sure that all files in the share are in the group
    chgrp -R "ABC/group" /home/Test

    As well, you could verify rights with something like
    chmod -R ug=rwX,o= /home/Test

    In smb.conf shares, my group shares have:
    create mask = 660
    force create mode = 660
    directory mask = 770
    force directory mode = 770

  3. #3
    tqz
    tqz is offline
    Just Joined!
    Join Date
    Jan 2008
    Posts
    50
    Hi Dustspeck and thanks for the quick response!

    Yes all the files in the share were owned by the abc group and they had complete rwx permissions when I checked the rights...

    I'm not too sure whether logging in and out of my computer (as i didnt want to restart the samba server as that would d/c users) or if i did something diff in my setup when creating the shares from scratch but all seems to be working fine now???

    I did things slightly diff though in terms of the order of steps (whether that would make any diff I dont know)...

    I created the directory Test at the command line (rather than using webmin), changed the ownership of the dir, edited the config file (keeping it simple and not adding the create or directory mask lines), changed the permissions of the dir to 770. All worked fine If i tried changing the ownership of a file to 770 before recreating the folder the problem would still exist...

    Thanks again!

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    you have to add them as a samba user using smbpasswd command

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •