Find the answer to your Linux question:
Results 1 to 5 of 5
Hello, I'm trying to setup my debian system so that I can access it's services from the internet I have my router set to forward ports 21, 22, and 80 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2010
    Posts
    8

    Ports forwarded but no connections accepted


    Hello, I'm trying to setup my debian system so that I can access it's services from the internet

    I have my router set to forward ports 21, 22, and 80 to the internal ip of the server, and internet port checking tools tell me the ports are open at my external ip.

    On the debian I am running Apache, ProFTPD, and SSH Server, and they all work fine for me inside the network, but whenever I try connecting with my external ip, all connections are immediately refused.

    So I don't know if its a problem with my router setup, with my debian system setup, or the setups of the servers.

    Any advice?

  2. #2
    mzv
    mzv is offline
    Just Joined!
    Join Date
    Aug 2009
    Location
    Evil Empire
    Posts
    33
    Do you have firewall enabled on the router or the server? Do you have access to its rules? Try to disable firewall for a time.

  3. #3
    Just Joined!
    Join Date
    Feb 2010
    Posts
    8
    The firewall on my router claims to be off and I did not install one on the linux server.

  4. #4
    Just Joined!
    Join Date
    Nov 2008
    Posts
    29
    Matt,
    you said your router is configured to forward packets to the *internal* address of your server. Surely, this is not correct.
    Also, are your services listening to your external address?

  5. #5
    Just Joined!
    Join Date
    Feb 2010
    Posts
    8
    "you said your router is configured to forward packets to the *internal* address of your server. Surely, this is not correct."

    By this, I mean the linux box, and several other systems, are connected to the router which provides internet access. What I meant by internal was the private network, 192.168.69.X

    The linux box is at 192.168.69.15, so I configured the router to forward ports 21, 22, and 80 to this address


    "Also, are your services listening to your external address?"
    Ahah, this helped. It seems the question I should be asking is "How do I setup each of these services to work behind a NAT?"

    For now, I am focusing on making proftpd accesible.

    Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •