Find the answer to your Linux question:
Results 1 to 2 of 2
I have three ethernet connections showing up, two from my onboard (ether & modem connections) and one from my PCI. I'm TRYING (much to my own headaches and dismay and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2009
    Posts
    24

    Frustration setting cards to eth(n) names.. major system slowdown, odd activity


    I have three ethernet connections showing up, two from my onboard (ether & modem connections) and one from my PCI. I'm TRYING (much to my own headaches and dismay and agony) to set it up so that the PCI card is eth0 and is static IP, and from there I'm not even worried about the other two. When I started, the PCI card was eth2 and one of the nVidia (onboard) was eth0, so I've tried just swapping them and it hasn't worked out so well.

    I'm experiencing major slowdowns (the system crawls at points, opening a console, rebooting, opening a text file...) but at other points seems to run at normal speed. The activity light on the PCI card seems to blink at odd times (like when I open a console).

    If anyone can diagnose where in the bloody world I've gone wrong, I'd appreciate it.

    As a note, I've tried ifrename on another machine, and that didn't work so well, and I don't have 70-persistent on this machine either. There HAS to be a way to do this though.

    My /etc/sysconfig/hwconf looks a bit like this:

    Code:
    class:NETWORK
    bus:PCI
    device:eth2
    driver:forcedeth
    desc:"nVidia Corporation (device name details)"
    network.hwaddr:  00:XX:48:XX:XX:04
    //other details
    -
    class:NETWORK
    bus:PCI
    device:eth1
    driver:forcedeth
    desc:"nVidia Corporation (device name details)"
    network.hwaddr:  00:XX:48:XX:XX:05
    //other details
    -
    class:NETWORK
    bus:PCI
    device:eth0
    driver:e1000
    desc:"Intel Corp ... Gigabit (device name details)"
    network.hwaddr:  00:XX:0c:XX:XX:bc

    So the onboard card has two ports (one for eth, one for phone line) and the PCI.

    Then I go to the Networking gui under System > Adminstration.

    Under the 'Hardware' tab I have:
    Code:
    Description            Type       Device   Status
    Intel Corp(decript)    Ethernet   eth0     ok
    nVidia (descript)      Ethernet   eth1     ok
    nVidia (descript)      Ethernet   eth2     ok
    When I click over to the 'Devices' tab, I have:
    Code:
    Profile      Status    Device    Nickname    Type
    Check      Inactive    eth1      eth1        Ethernet
    Check        Active    eth0      eth0        Ethernet
    Check      Inactive    eth2      eth2        Ethernet
    When I check each one's properties:
    Eth1: DHCP, do not start when computer starts up, Bound to MAC address 00:XX:48:XX:XX:05 (the one listed in hwconf for eth1), but when I click "Probe" it gives me error 19, no device.

    Eth0: Static IP, auto start device, bound to MAC address 00:XX:0c:XX:XX:bc, clicking probe shows no changes (presumably means the MAC is correct).

    Eth2: Static IP, auto start device, bound to MAC 00:XX:48:XX:XX:04, probe okay.

    ---

    Everything is running VERY slowly right now. Opening a console takes several seconds, and the activity light on the PCI card flashes several times (?). Restarting takes forever, cups takes forever to start up.. the card IS successfully loaded as eth0 though.

    Given the probe on eth1 said something was wrong, I tried unbinding it from that MAC and restarting. Same trouble. Tried making a copy of it that was inactive, not profiled, and then deleting eth1. Same problems.

    I don't know what in the world I'm doing wrong or what else to try. It's ridiculous that this should be this much of a pain. I'm no Microsoft fan, but I have to say this would be a matter of a few clicks in Windows...

  2. #2
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,672
    Have you tried to place the MAC addresses into the ifcfg-ethX config files? For example what every device you want to be eth0 edit ifcfg-eth0 and add HWADDR=<MAC>.

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •