Find the answer to your Linux question:
Results 1 to 8 of 8
So I just changed my network card settings recently, and I'm now getting no response when I ping the broadcast address for them... the cards are all connected through a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2009
    Posts
    24

    No ping broadcast response over small switch


    So I just changed my network card settings recently, and I'm now getting no response when I ping the broadcast address for them... the cards are all connected through a switch with IP addresses 192.168.0.x, broadcast 192.168.0.255... ifconfig on all of them shows UP BROADCAST RUNNING MULTICAST, but nobody responds to a broadcast packet. Any thoughts?

    EDIT: Pinging each machine individually works fine.

  2. #2
    Linux Enthusiast scathefire's Avatar
    Join Date
    Jan 2010
    Location
    Western Kentucky
    Posts
    626
    can the other machines broadcast?
    linux user # 503963

  3. #3
    Just Joined!
    Join Date
    Oct 2009
    Posts
    24
    Quote Originally Posted by scathefire View Post
    can the other machines broadcast?
    They don't get any responses either. The packets ARE getting through as far as I can tell because the activity lights on the cards flash in sync when I start broadcasting. Something just seems to be set up to discard / ignore them. Not sure what though..

  4. #4
    Linux Enthusiast scathefire's Avatar
    Join Date
    Jan 2010
    Location
    Western Kentucky
    Posts
    626
    well its really up to the OS as to whether or not it will actually respond to a direct broadcast. the switch, as long as it has no intelligence, will pass broadcasts.

    check this file to see if its set to ignore:

    cat /proc/sys/net/ipv4/icmp_echo_ignore_broadcasts

    if its 1, then its disabled change to 0 and it will respond
    linux user # 503963

  5. #5
    Just Joined!
    Join Date
    Oct 2009
    Posts
    24
    Right.. and the fact that the activity lights on all the NICs should indicate that they're at least being received, right? Just something somewhere in Linux is instructing it not to reply because it's a broadcast?

  6. #6
    Linux Enthusiast scathefire's Avatar
    Join Date
    Jan 2010
    Location
    Western Kentucky
    Posts
    626
    check the file i mentioned, yes they are received, but its being ignored if that is set to 1
    linux user # 503963

  7. #7
    Just Joined!
    Join Date
    Oct 2009
    Posts
    24
    Ugh, I actually stumbled across that online a few minutes ago but it didn't exist on my F10 box so I assumed it was a non-Fedora thing. It exists on the FC5 box back there, but I can't edit the file.. trying to write it fails (as root, of course).

  8. #8
    Just Joined!
    Join Date
    Oct 2009
    Posts
    24
    SOLUTION:

    1. As root, echo 0 > /proc/sys/net/ipv4/icmp_echo_ignore_broadcasts

    - OR -

    2. As root/sudo, add the following line to /etc/sysctl.conf: net.ipv4.icmp_echo_ignore_broadcasts = 0


    Thanks for the help scathefire

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •