Find the answer to your Linux question:
Results 1 to 3 of 3
I am building out or R710 with Redhat Linux ES 5.3 64-bit, but I’m having issues with the bonded interface. The machine has all sorts of trouble once I create ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2010
    Location
    Dulles, VA
    Posts
    3

    Problems Creating a bonded interface with Redhat ES 5.3


    I am building out or R710 with Redhat Linux ES 5.3 64-bit, but I’m having issues with the bonded interface. The machine has all sorts of trouble once I create the bonded interface. It gets into some sort of "Call Trace" mode (dump) and just locks up the box. I’ve tried a few different settings, but all seem to cause the problem.

    This is what I have for the interface settings.:

    Ifcfg-bond0:
    DEVICE=bond0
    IPADDR=192.168.XXX.XXX
    NETMASK=255.255.192.0
    ONBOOT=yes
    BOOTPROTO=none
    USERCTL=no

    Ifcfg-eth0:
    # Broadcom Corporation NetXtreme II BCM5709 Gigabit Ethernet
    DEVICE=eth0
    USERCTL=no
    ONBOOT=yes
    MASTER=bond0
    SLAVE=yes
    BOOTPROTO=none

    Ifcfg-eth1:
    # Broadcom Corporation NetXtreme II BCM5709 Gigabit Ethernet
    DEVICE=eth1
    USERCTL=no
    ONBOOT=yes
    MASTER=bond0
    SLAVE=yes
    BOOTPROTO=none

    I added the bonding parameters in the /etc/modprobe.conf file.

    modprobe.conf:
    alias eth0 bnx2
    alias eth1 bnx2
    alias eth2 bnx2
    alias eth3 bnx2
    alias scsi_hostadapter megaraid_sas
    alias scsi_hostadapter1 ata_piix
    alias bond0 bonding
    options bond0 mode=6 miimon=100

    I also tried putting the bonding options in the ifcfg-bond0 file.

    DEVICE=bond0
    IPADDR=192.168.XXX.XXX
    NETMASK=255.255.192.0
    ONBOOT=yes
    BOOTPROTO=none
    USERCTL=no
    BONDING_OPT="mode=1 miimon=100 primary=eth0"

    I then ran ‘modprobe bonding’ and restarted the network service. Everything seemed OK. But after a reboot, there are all sorts of problems. Any ideas/suggestions? Do I need to add ‘modprobe bonding’ to the rc.local file?

    Thanks

  2. #2
    Just Joined!
    Join Date
    Mar 2010
    Location
    Dulles, VA
    Posts
    3
    One thing I found that was odd was that eth0 is not showing an stats from the ethtool call. I get this:

    # ethtool eth0
    Settings for eth0:
    Link detected: yes

    If I run ethtool on any of the other 3 ports I get full stats:

    # ethtool eth1
    Settings for eth1:
    Supported ports: [ TP ]
    Supported link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Advertised auto-negotiation: Yes
    Speed: 1000Mb/s
    Duplex: Full
    Port: Twisted Pair
    PHYAD: 1
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: g
    Wake-on: d
    Link detected: yes

    So, I changed the bonded pair to eth1 and eth2, and it seems a little better. The odd thing now is that both interfaces show the same HWaddr, even though the HWaddr is set in the ifcfg-eth1/2 files.

    bond0 Link encap:Ethernet HWaddr A4:BAB:1A:CD:86
    inet addr:192.168.XXX.XXX Bcast:192.168.XXX.XXX Mask:255.255.192.0
    inet6 addr: fe80::a6ba:dbff:fe1a:cd86/64 Scope:Link
    UP BROADCAST RUNNING MASTER MULTICAST MTU:1500 Metric:1
    RX packets:6788 errors:0 dropped:0 overruns:0 frame:0
    TX packets:459 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:554635 (541.6 KiB) TX bytes:55072 (53.7 KiB)

    eth0 Link encap:Ethernet HWaddr A4:BAB:1A:CD:84
    inet addr:192.168.XXX.XXX Bcast:192.168.XXX.XXX Mask:255.255.255.224
    inet6 addr: fe80::a6ba:dbff:fe1a:cd84/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:29 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 b) TX bytes:9204 (8.9 KiB)

    eth1 Link encap:Ethernet HWaddr A4:BAB:1A:CD:86
    UP BROADCAST RUNNING SLAVE MULTICAST MTU:1500 Metric:1
    RX packets:3395 errors:0 dropped:0 overruns:0 frame:0
    TX packets:229 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:277027 (270.5 KiB) TX bytes:27629 (26.9 KiB)
    Interrupt:25 Memory:d8000000-d8012100

    eth2 Link encap:Ethernet HWaddr A4:BAB:1A:CD:86
    UP BROADCAST RUNNING SLAVE MULTICAST MTU:1500 Metric:1
    RX packets:3393 errors:0 dropped:0 overruns:0 frame:0
    TX packets:230 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:277608 (271.1 KiB) TX bytes:27443 (26.7 KiB)
    Interrupt:26 Memory:da000000-da012100

    I am beginning to think that this ES5.3 Kernel doesn’t support, or is at least missing some pieces, for interface bonding.

  3. #3
    Just Joined!
    Join Date
    Apr 2008
    Posts
    3
    Hi,

    I would verify cabling on eth0 as well as switch port setting that eth0 is plugging into.

    Regards,

    John K

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •