Find the answer to your Linux question:
Results 1 to 2 of 2
I've been trying for three days now to set up ssl port forwarding by RTFMing the documentation and googling the net, but I just don't manage to make it work ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Posts
    4

    ssh port forwarding - I'm stuck


    I've been trying for three days now to set up ssl port forwarding by RTFMing the documentation and googling the net, but I just don't manage to make it work the way I want it to. If there are anybody who'd like to point out what I'm missing, I'd be very happy.

    What I'm trying to do acchieve is this:

    Code:
    Server net              Internet             Internet
    +---------+             +---------+          +--------+
    |         |     ||      | ssh     |          |        |
    | Server  |-----||------| Proxy   |----------| Client |
    |         |     ||      |         |          |        |
    |         |             |         |          |        |
    +---------+             +---------+          +--------+
    
                 Firewall
    The proxy is mine, and of this I have full control. This is a linux 2.6.8-1 machine running OpenSSH 3.8.1p1.

    The server is some desktop windows pc in a private (192.168.x.x) network. I will have installed ssh client on this one (tried cygwin with OpenSSH and putty).

    The client is some arbitrary machine on the net.

    Normally, the server is not publishing anything on the net, and is not expected to either. However, at the leisure of the Server user, he wants Server to publish a service on the net, and send contact info to the client (using phone or email or some such). When the client is finished using the service, the user of Server shuts down the connection.

    What I've tried to do, is to make Server forward, say the service at port 80, on to a free unprivileged port on Proxy, like this:
    ssh -R 3500:server-ip-address:80 user@Proxy

    Using netstat, I can see that the port 3500 is getting bound on Proxy, and according to what I've read, this should be enough for the client to access the service on port 80 on Server.

    But I don't get it to work. I'm quite sure it's a trivial error, but I've become blind to what it may be.

    Can some friendly soul please point out to me what I am doing wrong, and what I need to add to my configuration? Or just point me in the direction of somewhere that explains what I'm missing?


    Regards
    Per Gunnar Hansų
    --
    Smile! It's free of charge.

  2. #2
    Just Joined!
    Join Date
    Nov 2004
    Posts
    4
    The anwer was to enable GatewayPorts in sshd_config.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •