Find the answer to your Linux question:
Results 1 to 3 of 3
I have an old PC running an older version of linux with two network cards serving as my firewall router. The network cards are netgear 310tx cards. Noticed traffic was ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2010
    Posts
    2

    Question Strange martian behavior when using switch vs hub


    I have an old PC running an older version of linux with two network cards serving as my firewall router. The network cards are netgear 310tx cards.

    Noticed traffic was not getting routed at times. Figured my switch was going bad, so I hooked up an old hub to keep keys systems communicating while I get a new switch. No problems with hub, but only has 5 ports.

    Get new switch (different make/model from old one), install, a couple of my systems have connectivity problems, but others do not. Thinking it was a bad switch, returned it, got a new one just like my old one (which I thought was going bad, but worked for several years).

    Hook it up, paying attention to my firewall console and notice martian header messages. Network traffic not getting routed at all. The interface for connected to LAN was slow to get started (my firewall can communicate to the Internet, but LAN communication was hosed).

    System would "hang" spitting out martian header messages until I disconnected LAN cable.

    Thinking network card may be bad, replaced it with another version of the same type. Same problems: martian header messages and traffic not getting routed.

    HOWEVER, if I remove the switch and use my old hub, no problems. Networking appears to work for all systems connected to hub.

    Since I and my wife work from home, I'm using the hub right now (with non-essential systems not connected due to limited ports). I can only do any real experimentation at night.

    I have no idea why things would work differently between using a hub vs a switch. Could something have gone awry with the linux kernel (2.4.20-46.7)?

    Any ideas on how to resolve and/or diagnose the problem would be greatly appreciated.

  2. #2
    Linux Engineer rcgreen's Avatar
    Join Date
    May 2006
    Location
    the hills
    Posts
    1,134
    I would suspect the network card. I don't know how old the
    design is, but some times there is an incompatibility.
    I have some cards that always run at 10 Mb half duplex
    because the switch wants to auto-negotiate but the
    card doesn't. If you force it to 100 Mb full duplex the connection
    slows to a crawl because of collisions. Try a newer card of a different
    type. Perhaps the reason the hub doesn't cause the same
    issue is that a hub doesn't do ARP. It broadcasts all traffic
    on all ports. The switch's extra intelligence may be just
    enough to cause a problem in rare circumstances.

  3. #3
    Just Joined!
    Join Date
    May 2010
    Posts
    2
    Is there some way to reset the card?

    I'm not knowledgable of how network cards and switchs work under-the-hood, but maybe some state in the cards is out-of-whack. I have done power-downs, restarts of the OS and network services, but no luck.

    Things were working with no problems for years. The last switch I hooked up is the exact same model as the original switch, but the hardware version is newer from the orginal, so maybe you are right that the newer model switches could be messing up how an older card operates.

    Wondering if there are switches on the market that are known to work without problems with systems using the netgear FA-310tx card.

    My old firewall box has worked for years with no hardware changes (except hard disk). I guess I may need to go thru the unfun task of getting new hardware and rebuild/reconfigure things.

    Is it possible the version of linux I'm using can be a contributing factor to the problem? It is a 2.4 kernel. Would updating things help or is something like this completely at the firmware/hardware level?

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •