Find the answer to your Linux question:
Results 1 to 5 of 5
On my laptop i have installed linux centos5. It is working fine and evrything works but their is one issue i can't find the solution for... I have installed some ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2010
    Posts
    3

    Some ports are available, others not but iptables are empty


    On my laptop i have installed linux centos5. It is working fine and evrything works but their is one issue i can't find the solution for...

    I have installed some servers:
    oracle DB running on 1521 with webinterface running on 81
    oracle weblogic server running on 7001
    apache running on 80

    The strange thing is that i only am able to connect to servers bound to port 80 and 8080.

    For examples localhost works fine but localhost:81 gets a connection refused.
    I also tried to change the port from 81 to 8080 and then it works.

    When i do a iptables -L nothing is their so no firewall rules.

    I realy don't have a clue were to look... It seems that their is somewhere still a firewall managing my network but i can't find it...
    The default port of WLS is 7001 when you install it and that does not work but when i change it to 8080 it does work...

    I have installed NetworkManager to manage my wireless connection. I have no wired connection.

    i also tried without the NetworkManager service and used the normal network service but that didn't help so perhaps NetworkManager is not the problem...

  2. #2
    Just Joined!
    Join Date
    Dec 2007
    Posts
    14
    I would guess that SELinux is affecting what has access to what ports. You can check what ports are permitted access by what services with
    Code:
    # semanage port -l
    To allow Apache to list on tcp to port 81 you could try
    Code:
    #semanage port -a -t http_port _t  -p tcp 81
    SELinux is set to Enforcing by default. You should read up and adjust your policies accordingly.
    Good luck.

  3. #3
    Just Joined!
    Join Date
    May 2010
    Posts
    3
    SELinux is disabled on my laptop

    Code:
    [root@localhost ~]# sestatus
    SELinux status:                 disabled

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    May 2010
    Posts
    3
    I think i just broke my linux...

    I enabled selinux because it was disabled and now i nothing sarts anymore.
    For every service i get an error "can not find shared library...."
    I can't even login to my gnome session. I have to use a failsafe session..

  6. #5
    Just Joined!
    Join Date
    Dec 2007
    Posts
    14
    Have you tried booting into single user mode and disabling SeLinux from there?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •