Find the answer to your Linux question:
Results 1 to 5 of 5
I am trouble trying to get vpnc to work on my laptop. Using the same computer via Ubuntu, it works fine. I used to use an older kernel with the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2010
    Posts
    6

    vpnc freezes computer with kernel 2.6.33-gentoo-r2, x86_64


    I am trouble trying to get vpnc to work on my laptop.

    Using the same computer via Ubuntu, it works fine.

    I used to use an older kernel with the cisco vpn client, but had to go through the motions of turning off cpus in order for it to work. I gave that trick a try and it does not work.

    I pretty much followed the instructions from:
    Gentoo Linux Documentation -- Gentoo vpnc HOWTO

    The machine completely locks up right after I enter my password...

    I don't see anything relevant in the /var/log/messages file.

    Is there another log file to look into specific to the vpnc?

    Any one have any suggestions....

    Thanks

  2. #2
    Just Joined!
    Join Date
    Jul 2010
    Posts
    6

    vpnc freezes computer HELP!! Linux VPN/ Netwrok Expert!

    Hi,

    I am still trying to get VPNC to work on gentoo linux, kernel version 2.6.33, x86_64.


    The problem occurs as soon as I enter the password and it tries to make its connection.

    I am tailing the /var/log/messages and doing a dmesg command via a loop, and running tcpdump.

    Here is what happens:

    as root
    > # vpnc
    Password for VPN username@XXXXX@ipaddress
    VPNC started in background (pid: 2344) ...
    > #

    System completely freezes

    in dmesg output & logfile output I see:

    [9309.539025] tun: Universal TUN/TAP device driver, 1.6
    [9309.539027] tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>

    tcpdump relatd output shows:
    09:58:03.062988 IP computer.ipsec-nat-t > DestMachine.ipsec-nae-t: NONESP-encap: [|isakmp]
    .
    .
    .
    09:58:03.124601 IP DestMachine.ipsec-nae-t > computer.ipsec-nat-t: NONESP-encap: [|isakmp]
    09:58:03.124746 IP computer.ipsec-nat-t > DestMachine.ipsec-nae-t: NONESP-encap: [|isakmp]
    09:58:03.126574 IP DestMachine.ipsec-nae-t > computer.ipsec-nat-t: NONESP-encap: [|isakmp]
    09:58:03.126727 IP computer.ipsec-nat-t > DestMachine.ipsec-nae-t: NONESP-encap: [|isakmp]
    09:58:03.128784 IP computer.ipsec-nat-t > DestMachine.ipsec-nae-t: NONESP-encap: [|isakmp]

    Can anyone tell me what to look for/what settings to check, etc.
    What to check in kernel, what setting could be missed ? ? ?


    Thanks !!!

    Jamie

  3. #3
    Just Joined!
    Join Date
    Aug 2010
    Posts
    2
    you find a fix by any chance?

  4. #4
    Just Joined!
    Join Date
    Jul 2010
    Posts
    6

    Got VPNC working [solved]

    In order to get mine to work, I disabled configuration options that I previously set in the kernel for KVM:
    unchecked Virtualization, left TUN/TAP as module, and unchecked bridging & Vlan support, see below.

    Works now without crashing.

    Also to note, I believe you must load TUN first before running vpnc
    modprobe tun

    [ ] Virtualization --->


    # this needs to still be checked for VPNC, so I left that
    Device Drivers --->[*] Network device support --->
    <M> Universal TUN/TAP device driver support

    Networking options --->
    <*> 802.1d Ethernet Bridging │ │
    │ │ <*> 802.1Q VLAN Support

  5. #5
    Just Joined!
    Join Date
    Jul 2010
    Posts
    6

    vpnc can't connect internet once connected to VPN

    After connecting vpn using vpnc. I can not access the internet. My /etc/resolv.conf seems ok, but I am guessing there must be some addition routing that needs to be done.

    Does anyone know how to do this?

    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •