Find the answer to your Linux question:
Results 1 to 8 of 8
Hi all! Thanks for reading. I just installed PCLinuxOS 2010.07 KDE desktop. Great distro simple and straight forward. It's installed on an IBM laptop and all the periperals are working ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2010
    Posts
    6

    Question Smb4k can't see windows 7 shared folders


    Hi all! Thanks for reading.

    I just installed PCLinuxOS 2010.07 KDE desktop. Great distro simple and straight forward. It's installed on an IBM laptop and all the periperals are working fine.

    My network architecture consists of three computers hardwired to a hub one desktop and 2 laptops (one of them being the linux machine). Consequently, the hub is wired to a router and another computer is wired in to the router. The desktop D1 that is connected to the hub has Windows 7. L1 is a laptop with winXP and the laptop L2 has PClinuxOS. The other desktop D2 connected to the router has WinXP. In other words, D1 L1 & L2 are connected to a hub which is then refered to a router and D2 is connected to the router.

    Now, when I use SMB4k with L2(PCLOS) I CAN view the shared folders on D2(winXP) with no problem. This part worked right off the bat. The problem is with D1 (Win 7). I CANNOT view the shared folders with SMB4k. SMB4K can detect the machine D1 the IP address, but when I click on it so SMB4K can query the host nothing happens. The list never gets displayed. As opposed to the XP machine D2 where I can view access and even copy a file over to my PCLinuxOS desktop through SMB4K.

    D1 (win 7) has the firewall disabled. The workgroup is WORKGOUP on all machines.

    I think the problem might be on the level of the file sharing configs on D1. However, when on D2(winXP) I can access all the shared folders on D1(win7) with no problem and vise versa. Basicely, all the machine on my network that are windows based can detect each other and share files except the one with PCLinuxOS and Win7. I havent tried sharing any folders on L2. I wish to first access files from D1.

    Please ask me any addictional info if it's missing or if my post is unclear. I asked google in many different ways and nothing fitting my discription came up. Please help. Thank you!

  2. #2
    Just Joined!
    Join Date
    Jul 2010
    Posts
    6
    Hi again!

    I want to access my WINDOWS 7 shared folders. As in shared on the network! When I use SMB4k on PCLINUXOS 2010.07 it doesnt work. WHY????

    Does anybody know this? Am I in the right section of the forum for such a problem? IF yes then can someone please help. I am in a cul de sac.

  3. #3
    Just Joined!
    Join Date
    Apr 2010
    Posts
    18
    I am not an expert, but I found a workaround that seemed to help,
    although I don't really know why it was necessary.
    Open up the PClinuxOS control center/Network/host definitions.
    Hit "Add".

    Add an entry for the Windows box. Give it the Netbios name and the IP
    address.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jul 2010
    Posts
    6
    Thanks Bud! I will try it and let you know how it went.

  6. #5
    Just Joined!
    Join Date
    Jul 2010
    Posts
    6
    No luck didn't work.

    When I clicked on ADD in the host definition, I typed the IP adress given by my router for the PC with win7 and for the HOST name, I called it what is usually seen in SMB4K and for the host alias I figured was not important so I wrote poto.

    Do you see any problems here? Thanks dude!

  7. #6
    Just Joined!
    Join Date
    Apr 2010
    Posts
    18
    I made my host name and alias the same (the windows host or netbios name)
    I guess you could try it, but if it doesn't help, have you looked on the Windows side ?

    Is the Guest account active ?

    I was going to leave you the URL of an article about this,
    but I'm not allowed to post URL's cause I haven't made 15 posts yet!

  8. #7
    Just Joined!
    Join Date
    Jul 2010
    Posts
    6
    LOL...Well maybe you can tell what to write in google so that I can find the same article instead writting the URL?

    Guest accounts dont help. I can see the computer in SMB4K but I can go any further meaning the shared folders are not appearing.

    Thanks!

  9. #8
    Just Joined!
    Join Date
    Apr 2010
    Posts
    18
    OK. Take a look at this link, see if anything helps: (If you can find it!)

    Fedoraforum.org
    search for posts

    search on "can't mount one of my Windows machines"
    (title only search/Networking section - post is dated 4/16/10)

    It describes further why Linux may not be able to see WIndows machines properly.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •