Find the answer to your Linux question:
Results 1 to 9 of 9
Hi, I have just installed Yoper 2.1, and am getting really slow internet - i should get about 110 KBs, but it is running no where near that - it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2003
    Location
    London, UK
    Posts
    5

    Very slow internet / Yoper 2.1


    Hi,

    I have just installed Yoper 2.1, and am getting really slow internet - i should get about 110 KBs, but it is running no where near that - it generally goes at about 50ish, and when i have a download going, it often totally stops all other internet traffic. Its as if it is being limited by something

    I have seen there is an IPv6 problem, but it would appear i dont have IPv6, as it is not in the kernel/net folder.

    The kernel version is 2.6.8

    I have tried turning off guarddog - the firewall that yoper uses.

    Any one got any ideas?

    Thanks

  2. #2
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    I had a problem similar to this when using kde, which sucked all of the resources from my old system, a change to fluxbox helped alot I went from timing out and 5 or so k to 500k+ which is where it should be...not sure if this is relevant to your problem though or not, but a lower memory resource intensive xwm sure helped me alot.

  3. #3
    Just Joined!
    Join Date
    Sep 2003
    Location
    London, UK
    Posts
    5
    Not sure it would be low resources - this machine has a gig of ram in it, and i am sure KDE isnt hogging THAT much!

    My laptop, running mandrake and KDE doesnt have any such problem

  4. #4
    Just Joined!
    Join Date
    Sep 2003
    Location
    London, UK
    Posts
    5
    Hmmm - i have just started downloading a file with KGet, which appears to give you second by second transfer rates - the rates are varying wildly, from about 30kbs to 110kbs, but getting gradually slower as the tranfer progresses - i dont get what could be causing this

    Any ideas?

  5. #5
    Just Joined!
    Join Date
    Nov 2004
    Location
    Christchurch
    Posts
    12
    Quote Originally Posted by [=hris
    Hmmm - i have just started downloading a file with KGet, which appears to give you second by second transfer rates - the rates are varying wildly, from about 30kbs to 110kbs, but getting gradually slower as the tranfer progresses - i dont get what could be causing this

    Any ideas?
    It happens all the time to me except usually i start at 4096Kbps down to 2048Kbps and stays at about 1500Kbps. I think thats only with ADSL, though.

  6. #6
    Just Joined!
    Join Date
    Sep 2003
    Location
    London, UK
    Posts
    5
    In windows i get a sustained rate of about 110 / 115 Kbs - in linux, i am lucky to get 50Kbs

  7. #7
    Linux User
    Join Date
    Sep 2003
    Posts
    254
    Quote Originally Posted by [=hris
    I have seen there is an IPv6 problem, but it would appear i dont have IPv6, as it is not in the kernel/net folder.
    Try to recompile ur kernel with the IPv6 options if u think that the problem comes from here

  8. #8
    Just Joined!
    Join Date
    Sep 2004
    Location
    Manchester
    Posts
    50
    I had a slow speed connection issue, Topper pointed me to this link
    http://www.apu.edu/imt/awg/node/view/101

    did the trick for me, maybe it will help you .

  9. #9
    Just Joined!
    Join Date
    Nov 2004
    Location
    New Zealand
    Posts
    20
    I take it you are using kde 3.3.x? I had problems with internet speed in KDE too.
    It seems that IPV6 support in kde 3.3 is turned on by default, so if your ISP's DNS servers don't understand IPV6 (most of them AFAIK) kde apps will waste a lot of time sending IPV6 requests before they fall back to IPV4.
    To find out if this is your problem you need to set the environment variable 'KDE_NO_IPV6' to '1'.

    Just put
    Code:
    export KDE_NO_IPV6="1"
    in a startup script somewhere (/etc/init.d/local or /etc/X11/Xsession or something) so that it gets run before KDE starts.

    Hope this helps.

    Steve.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •