Having obtained an ECS A535 laptop and proceeded to install Fedora Core 2 on it, I tried to get wireless networking to work, but to no avail. This excellent review did help quite a bit; I downloaded and installed the linux-wlan-ng-0.2.1pre22 drivers (first I configured a 2.6.8-1.521 kernel, used "make all && make modules_install && make install" on it, then ran "make all && make install" for linux-wlan-ng. Booting into the new kernel, I could detect a wireless network with signal strength 90%, but not use it to access the Internet or ping any sites. I also tried a few extra things, such as adding "alias wlan0 prism2_usb" to /etc/modprobe.conf, using system-config-network to make wlan0 activate on boot, and writing a startup script

Code:
                                                                                                                         modprobe -r prism2_usb
modprobe -r p80211
modprobe prism2_usb
sleep 5
ifup wlan0
I tried appending this script to /etc/rc.d/rc.local and placing it in /etc/init.d with a symbolic link to it from /etc/rc.d/rc5.d/S07wlan such that it would be executed before S08iptables, S09wlan (which happens to be the rc.wlan script provided with the drivers) and S10network, but to no success. In the end, I still had the same outcome: I could detect a wireless network sometimes but not use it; and the wireless network wasn't detected all the time (only once in many reboots).

In case it helps, the output of "ifup wlan0" when I cannot detect a network is
Code:
prism2_usb device wlan0 does not seem to be present, delaying initialization.
The output of "lsmod" is:
Code:
Module                  Size  Used by
ppp_synctty             9216  1
ppp_generic            25876  5 ppp_synctty
slhc                    6912  1 ppp_generic
n_hdlc                  9092  1
snd_mixer_oss          16512  0
snd                    44900  1 snd_mixer_oss
soundcore               8416  1 snd
autofs4                17924  0
prism2_usb             66052  0
p80211                 29328  1 prism2_usb
ipt_REJECT              6784  1
ipt_state               2560  4
ip_conntrack           28936  1 ipt_state
iptable_filter          3200  1
ip_tables              16256  3 ipt_REJECT,ipt_state,iptable_filter
sg                     33824  0
scsi_mod              101456  1 sg
dm_mod                 49404  0
joydev                  9024  0
ohci_hcd               19600  0
ehci_hcd               27396  0
button                  6680  0
battery                 9100  0
asus_acpi              10904  0
ac                      5260  0
Does anyone know how to solve this? Thanks in advance.