Find the answer to your Linux question:
Results 1 to 5 of 5
I don't understand what's happening here. I installed MNF to configure a DMZ for our Network, I have 3 NIC's Installed eth0: LAN eth1: WAN eth2: DMZ I have 3 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Posts
    3

    MNF - Trouble Moving IPs behind the DMZ


    I don't understand what's happening here.

    I installed MNF to configure a DMZ for our Network, I have 3 NIC's Installed


    eth0: LAN
    eth1: WAN
    eth2: DMZ

    I have 3 servers I'm trying to put behind the DMZ, they consist of a DNS/FTP Server, IMap Server, WWW Server.

    DNS/FTP = .2
    WWW = .3
    IMap = .4

    When I first attempted it, I tried all three machines once, which didn't pan out.

    Then I tried moving the least critical server (WWW), It moved just fine, I have it NAT'd and ProxyARP'd and all the required rules setup.

    I then tried moving the IMap server, it appeared to work, but... From the LAN Zone, I can talk to it, and from WAN Zone I can talk to it if the machine trying to access it is on the network behind our Router and outside the firewall, but if a completely outside party tries to access the server, if gets no response. I'm at a complete loss... I fear that If I attempt to move the DNS/FTP Server I will have the same result.

    I've tried several things (change NIC, Different Internal Address, Banging Head Against Wall), I've even allocated a test IP address of .10, which will work from everywhere, but as soon as I attempt to use .4 it will not work outside our Router... Has anyone else heard of this happening and how to resolve it, I can not change the IP address of these machines because of client configurations

    Any Help is greatly appreciated.
    Comkid

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    What's this "MNF" thing?

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Posts
    3
    Mandrake's "Multi Network Firewall"

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Oh, it's a Mandrake thing? That could explain why I haven't heard of it. =)

    Is it just a set of iptables rules? If so, could you post the iptables settings, interface settings and your routing tables? That is, the output of these commands:
    Code:
    iptables-save
    ip addr ls
    ip route ls

  6. #5
    Just Joined!
    Join Date
    Nov 2004
    Posts
    3
    I do not believe it is, because the sample ip of .10 works fine, it's only when I try to use real ip for the machine of .4, because of the setup, I don't have it setup that way at the moment, I've have to try it again and then attempt to post that information

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •