Find the answer to your Linux question:
Results 1 to 5 of 5
I have an old laptop trying to mount a share with samba on a server. laptop and server both running ubuntu 9.04. When I try to mount a share on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2010
    Posts
    11

    samba asking for password - guest share enabled


    I have an old laptop trying to mount a share with samba on a server. laptop and server both running ubuntu 9.04.

    When I try to mount a share on the server

    $ mount -t cifs //192.168.1.3/home/stuff /mnt/music

    I get a password prompt, and no server passwords work. This is a guest share, and my two windows laptops mount it no problem with no password.

    here's the relevant part of the smb.conf:

    [Guest Share]
    comment = Guest access share
    path = /home/stuff/
    browseable = yes
    read only = no
    guest ok = yes

    laptop and server are on the same workgroup. any thoughts? extensive googling hasn't turned up anything.

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,706
    So, are you logging in as "guest", or someone else?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Apr 2010
    Posts
    11
    Quote Originally Posted by Rubberman View Post
    So, are you logging in as "guest", or someone else?
    I'm not logging in as anyone -- I mean, I thought the point of a guest share was that you don't have to log in, and you can just mount a shared filesystem with no usr/pwd.

    That's the way it works when I connect from my windows machines. Am I wrong?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,706
    Try mounting with the option -o user=guest
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  6. #5
    Just Joined!
    Join Date
    Apr 2010
    Posts
    11
    thanks rubberman, but still getting a password prompt. i've switched over to sshfs, which prompts me for a password, but at least the password works.... doesn't seem to affect things that the server is sharing the same directory via sshfs and samba, so i'm gonna go with it for now.

    thanks again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •