Find the answer to your Linux question:
Results 1 to 7 of 7
I just got a wireless card and I've been having connection issues under Linux. The chipset I have is a Ralink 2860 (the card itself is an Asus PCE-N13) and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2010
    Posts
    10

    Wireless connection slow and unreliable


    I just got a wireless card and I've been having connection issues under Linux.

    The chipset I have is a Ralink 2860 (the card itself is an Asus PCE-N13) and supports 802.11n speeds up to 300 mbps. I am connecting to a DLink DIR-655 router, which also supports 802.11n at 300 mbps. I get full bars when connecting to my router, and my router's connection information shows my computer connected as 802.11n with the signal at around 80%, but the data rate is usually around 5.5 mbps. (I've rarely seen it go up to 18 mbps) I can confirm this woefully slow speed with anything I try to do over the network. Additionally, my wireless connection will sometime be disconnected and network manager will often fail to connect. When it fails to connect, my router lists my comptuer with the correct IP address, so I know it is successfully connecting to the router and the router is accepting the connection, but network manager seems to not recognize this.

    I am running Debian Squeeze (testing), but I have a custom kernel, which is 2.6.35 and is using Debian's kernel configuration. I have the newest firmware from Ralink's website, and I also tried the newest drivers, which made no difference. (I have since removed those drivers, since I'd prefer to use the drivers supplied with the kernel if possible, but I can install them again if necessary) I put this card in my main computer and booted under Windows, and it was able to connect with 100% signal (it's right next to the router) and at 300 mbps. I also tried it under Debian on my main computer (with the stock 2.6.33 kernel), but it only connected as 802.11g, and even at 100% signal it was only connected at 36 mbps. For comparison, my laptop with an 802.11g card and running Mac OS X can achieve the full 54 mbps at 84%.

    Here is the output from iwconfig:
    Code:
    wlan0     IEEE 802.11bgn  ESSID:"d20"  
              Mode:Managed  Frequency:2.417 GHz  Access Point: 00:18:E7:EF:EA:9E   
              Bit Rate=48 Mb/s   Tx-Power=14 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              Link Quality=70/70  Signal level=52 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    Can anybody help me get a proper speed from my wireless card?

  2. #2
    Just Joined!
    Join Date
    Sep 2010
    Posts
    10
    I just realized that I had missed the wireless forum, despite the fact that it is right above this one. If a mod can move this thread there, I would appreciate that.

    Just to add another bit of information, right now the computer I have the wireless card hooked up to is right next to the wireless router and has 100% connectivity, but it is only connected at 78 mbps.

  3. #3
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    I don't know that there is a solution out there right now. The rt2860 is in the staging area of the kernel, no? Which means it's not of sufficient quality to make it into the mainline kernel.

    As the Debian wiki says, "This driver is buggy."

    One thing I do notice that perhaps will make a difference, your bitrate is listed as 48 Mb/s in your iwconfig output. Do as root
    Code:
    iwlist wlan0 scan
    This will output available networks. Locate yours, and you should see listed available bit rates. Ex
    Code:
     Cell 03 - Address: C0:3F:0E:0A:2D:32
                        Channel:6
                        Frequency:2.437 GHz (Channel 6)
                        Quality=58/70  Signal level=-52 dBm
                        Encryption key:on
                        ESSID:"Your mom"
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                                  24 Mb/s; 36 Mb/s; 54 Mb/s
                        Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
    Change to an available bit rate
    Code:
    sudo iwconfig wlan0 rate 54M
    As for networkmanager, many people find wicd to work better for them.

  4. #4
    Just Joined!
    Join Date
    Sep 2010
    Posts
    10
    Thank you for the reply. When I scan, it only shows 54 Mb/s available, but setting it through iwconfig doesn't seem to do anything.

    I did some more research online, and it looks like one issue I was having was too many drivers were being loaded. I blacklisted the drivers rt2800pci and rt2x00pci, and that made it work with the rt2860sta driver. After that, I was able to connect to my network, as there was a while where I couldn't connect no matter how many times I tried. I then installed the newest drivers from Ralink's website, renaming the old driver in staging and blacklisting it. I know that the new driver is working, since my wireless is now available at ra0 instead of wlan0. It does appear to give me slightly better performance, and when it's right next to the router it shows as being connected at 130 Mbps (as opposed to the 78 Mbps before), though transferring a file through scp only shows a transfer rate of about 2.3 MB/s. (or 18.4 Mbps) Additionally, iwconfig lists the signal strength at 62/100 and the transfer rate at 65 Mbps, even when it's right next to the router.

    This is rather frustrating, since I specifically looked to make sure that this card and chipset would work with Linux before buying. There are many people online that have mentioned that this chipset works well under Linux with fast connections. I don't know if it's this particular model, or maybe the driver got screwed up with an update or only works well with older kernels, or just other people's definition of fast really means snail slow, but it doesn't seem to be working well for me...

    Edit: I just blacklisted the rt2860sta driver and used the rt2x00pci driver instead, and I appear to get similar performance to the rt2860sta driver, and it seems to connect faster when it's not right next to the router as well. So it looks like the connection is more stable, but it's still very slow.
    Last edited by akb825; 10-02-2010 at 10:08 AM.

  5. #5
    Just Joined!
    Join Date
    Sep 2010
    Posts
    10
    I've given up on my pci-e wireless card and got an IOGEAR Wireless N USB adaptor based on the AR9170 chipset. My router shows the connection speed at 52 Mbps - 104 Mbps, and the speeds I am observing are several times higher.

    I don't appear to be getting the full speeds that my router is reporting, though, as I'm getting about 1.3 MB/s on scp and about 580 KB/s for the internet. (vs 1665 KB/s on the same test site on my main computer) Is that a reasonable difference to expect, or is something somehow configured wrong? I tested a few 1080p youtube videos, which played smoothly and without pauses for buffering, and I think this should be fast enough for general use, but it would be nice to get faster speeds so file transfers can be a bit more practical.

  6. #6
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    As it happens, I also have a ra2860.
    Works great, full signal. And it supports a max of 54 Mbps.
    My net connection at home is a 10 Mbps.
    When I download a file from a reliable source, I get a throughput of 1.2 MBps (notice the difference there). 1.2 MBps = 10 Mbps.

    Looks like you're actually doing just fine.
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  7. #7
    Just Joined!
    Join Date
    Sep 2010
    Posts
    10
    Quote Originally Posted by jayd512 View Post
    As it happens, I also have a ra2860.
    Works great, full signal. And it supports a max of 54 Mbps.
    My net connection at home is a 10 Mbps.
    When I download a file from a reliable source, I get a throughput of 1.2 MBps (notice the difference there). 1.2 MBps = 10 Mbps.

    Looks like you're actually doing just fine.
    I did take the conversion from MB/s to Mbps into account. Not that I blame you for missing that, since at this point I have several tests in different locations with 2 different wireless devices on a desktop (one of which with a total of 3 different drivers) as well other tests with a separate laptop, so it's getting pretty confusing...

    As I mentioned, at my desktop's location my router reports the connection speed at 52 Mbps - 104 Mbps depending on its mood. When doing a file transfer to another computer on my local network (through scp) I observed around 1.3 MB/s, or 10.4 Mbps. My observed internet speeds were around 4.5 Mbps, compared to 13 Mbps on the same site and the same time for my computer hooked up by a wire.

    That said, I ran some tests with my Mac laptop, which has wireless G. I was observing 2.5 MB/s (or 20 Mbps) with a local file transfer with my laptop when it was right next to my router, despite the router saying it was connected at 54 Mbps. When right next to my wireless desktop, the transfer speeds dropped to lower than what I'm observing on the desktop with the USB dongle. I think right now I'm just running into the overhead of the wireless connection.

    To recap the thread so far:
    - I originally got a PCI-Express wireless card with the Ralink 2860 chipset, which I was getting slow speeds and couldn't connect reliably with under Linux. Even next to the router I wouldn't get full connection speed. Windows would register the full connection speed.
    - I found out that part of the issue was too many drivers were being loaded. (both rt2860sta and rt2800pci were trying to control the hardware) After blacklisting one or the other, I was able to more reliably connect, but still got poor throughput using the 2 drivers that came with the kernel as well as the manufacture's driver.
    - I picked up a USB network dongle based off the AR9170, and observe much better speeds, and is fast enough for what I need it for.
    - I observe less than 1/4 the speeds that the router says I'm connected at. Internet download speeds are reduced even further compared to local transfers. After further tests it still beats out my laptop in the same location, so I think I'm just hitting the limitations of what wireless can actually do.

    Other thoughts:
    I think at least part of the slowdown with the PCI-express card was the fact that the signal had to travel through the computer in order to get to the router due to its location. The USB dongle is better off because it came with a USB extension cord, allowing me to place it in a location with less interference. However, even right next to the router with 100% signal the PCI-express card was connecting at less than half the speed it should have.

    Assuming the difference in speeds from what the router reports and what I actually see with real world tests are due to the overhead of wireless itself, I think reported wireless speeds are very misleading. It's like somebody said "here's the $100 I promised you" then handed you $30. Sure, they may be able to say "oh, the processing fees came out about $70", but you'd still be pretty pissed. I understand the advertised speeds are in the absolute best case conditions, but if the router says it's connected at a certain speed, I would expect to actually observe that speed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •