Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
I am using Angstrom Linux and what I would like to do is access the terminal through a GPRS network. At the moment, I am able to do this through ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2010
    Posts
    9

    Using SSH on Mobile network


    I am using Angstrom Linux and what I would like to do is access the terminal through a GPRS network. At the moment, I am able to do this through LAN but can't get it to work through GPRS.

    I have Dropbear running on the Linux board I want to access and I am connected to Orange GPRS network. On the host, I am using Putty to make the connection.

    Can someone help me out with this? I can provide more information if required, just let me know what you need....

    Thanks

  2. #2
    Linux Engineer Kloschüssel's Avatar
    Join Date
    Oct 2005
    Location
    Italy
    Posts
    773
    hi & welcome to the forum

    Draw a map for the route from your device you want to connect from to the target device you connect to. Then check for each gateway (device with an ip) along that path if the packets are properly forwarded (through NAT or whichever means) and not blocked by firewalls in both directions. I promise that you'll find the error.

    To map the route you can use tracepath.

  3. #3
    Just Joined!
    Join Date
    Oct 2010
    Posts
    9
    I don't have tracepath, but I do have traceroute so I used that. No matter what address I put into it, I always get the same output....

    sudo traceroute www .google.com
    traceroute to www .l.google.com (173.194.36.104), 30 hops max, 38 byte packets
    1 172.26.x.x (172.26.x.x) 963.350 ms 718.365 ms 999.730 ms
    2 172.26.x.x (172.26.x.x) 699.553 ms 2608.903 ms 589.584 ms
    3 172.25.x.x (172.25.x.x) 589.788 ms 708.831 ms 999.666 ms
    4 172.25.x.x (172.25.x.x) 659.736 ms 708.746 ms 1059.858 ms
    5 * * *
    6 * * *
    7 * * *
    8 * * *
    9 * * *
    10 * * *
    11......................

    And so on.... It repeats 30 times without reaching the site. However, I am able to ping it. Also, the addresses shown are private addresses (172.x.x.x), should they be?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer Kloschüssel's Avatar
    Join Date
    Oct 2005
    Location
    Italy
    Posts
    773
    Usually the network maps like this:

    <host a> -- <gateway a> -- <internet> -- <gateway b> -- <host b>

    In order that ssh works following must hold:

    * <host a> can reach <internet> through port 22
    * <host b> can reach <internet> through port 22
    * <internet> can reach <host a> through port 22
    * <internet> can reach <host b> through port 22

    A common error is that either port 22 is blocked at some point or not forwarded properly.

  6. #5
    Just Joined!
    Join Date
    Oct 2010
    Posts
    9
    Does my traceroute output look right to you?

  7. #6
    Just Joined!
    Join Date
    Oct 2010
    Posts
    9
    Quote Originally Posted by Kloschüssel View Post

    A common error is that either port 22 is blocked at some point or not forwarded properly.
    Yes, my ISP is Orange and I think they may be blocking the port. I've tried using different ports with no success. But then again, I don't know if the IP I'm using when trying to connect through SSH is correct. Linux reports my IP as 10.x.x.x, which is Private. A whatismyip website reports my IP as 172.24.x.x, which I believe is also private. So which of these should I use, if any?

    I don't have much experience with networks...

  8. #7
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,934
    You would need to talk to your ISP/Carrier about the blocking of ports. There are a couple of things you could try though...

    Try putting your SSH server onto a port > 1024, something like 2222 or 22222 would be easy to remember (don't forget to restart sshd). You can specify the port with -p on the SSH connection command line.

    If your Orange still block these ports, then you could try doing this over port 80 - which is normally used by http traffic. It's less likely to be blocked, but more likely to suffer from odd ISP bandwidth-controlling proxying, so you may find that doesn't work either.

    I use SSH from my phone into my server over Vodafone using a port > 1024 and I have no problems.
    Linux user #126863 - see http://linuxcounter.net/

  9. #8
    Just Joined!
    Join Date
    Oct 2010
    Posts
    9
    I've tried those ports and they arent working. I tried a different site to get my external IP and it reports 193.35.x.x, which seems good to me. But every time I access that site it reports back the last number differently. So is my IP changing every time I try to do something? SSH to any of these IPs using different ports doesnt work either.

  10. #9
    Linux Engineer Kloschüssel's Avatar
    Join Date
    Oct 2005
    Location
    Italy
    Posts
    773
    Usually your IP changes only with a disconnect/connect operation. Still it may be possible that your GPRS ISP does that automatically for you. i.e. he does for each connection attempt a dialup and after that he disconnects automatically. Fairly uncommon, but plausible and IMHO one should not able to sell a solution like that as internet.

    Is the server you want to SSH into reachable from the internet on port 22? Just like one of the servers from my former university: zid-gpl dot uibk dot at?
    Last edited by Kloschüssel; 10-20-2010 at 01:13 PM.

  11. #10
    Just Joined!
    Join Date
    Oct 2010
    Posts
    9
    Well I don't think it is. I've tried all the different IP's I've been getting and none of them seem to work. It is strange that my external/public IP seems to change so often though, I don't understand that. Not sure what to do now...

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •