Find the answer to your Linux question:
Results 1 to 3 of 3
I have a machine (mercury) on which /home/hyperhacker/video is a mounted external hard drive while the rest of /home/hyperhacker is on the internal hard disk. I have a second machine ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2009
    Posts
    24

    Question NFS autofs can't see mounted subdirectory


    I have a machine (mercury) on which /home/hyperhacker/video is a mounted external hard drive while the rest of /home/hyperhacker is on the internal hard disk. I have a second machine (konata) using autofs to automatically mount mercury:/home/hyperhacker in /mnt/mercury as needed. This works, except /mnt/mercury/video shows up empty.

    mercury:/etc/exports has:
    Code:
    /home/hyperhacker       konata(ro,subtree_check)
    /home/hyperhacker/video konata(ro,subtree_check)
    and I've tried a few variations in konata:
    Code:
    $ cat /etc/auto.master
    [...]
    +auto.master
    /mnt /etc/auto.mercury
    /mnt/mercury/video /etc/auto.mercury.video
    $ cat /etc/auto.mercury
    *       mercury:/home/hyperhacker
    $ cat /etc/auto.mercury.video
    *       mercury:/home/hyperhacker/video
    /mnt/mercury mounts automatically, but /mnt/mercury/video still shows up empty. I can only manually mount it:
    Code:
    $ sudo mount mercury:/home/hyperhacker/video /mnt/mercury/video
    Then the contents show up, so mounting works. Just autofs doesn't seem to handle it... probably I've done something wrong in the config?
    Last edited by HyperHacker; 10-21-2010 at 05:20 AM. Reason: typo in config, but fixing it didn't help.

  2. #2
    Just Joined!
    Join Date
    Oct 2010
    Location
    Reston, VA
    Posts
    26
    Not sure. Have you tried listing the directories in the reverse order?

    /mnt/mercury/video /etc/auto.mercury.video
    /mnt /etc/auto.mercury


    -Gooney0

  3. #3
    Just Joined!
    Join Date
    Jun 2009
    Posts
    24
    No good. Still can't see anything in /mnt/mercury/video unless I explicitly mount it.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •