Find the answer to your Linux question:
Results 1 to 2 of 2
Hi guys, I can't set up network card on one of my old laptop(Toshiba Satellite M40x) The output of the command "uname -rmi" is 2.6.18-164.e15.vnow i686 i386 output of lspci ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2010
    Posts
    1

    eth0: link is not ready, link down


    Hi guys,

    I can't set up network card on one of my old laptop(Toshiba Satellite M40x)

    The output of the command "uname -rmi" is
    2.6.18-164.e15.vnow i686 i386

    output of lspci | grep eht
    06:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139c/8139c+ (rev 10)

    The module 8139too has also been loaded
    the output of lsmod | grep 8139 is
    8139too 28993 0
    8139cp 26561 0
    mii 9281 2 8139too,8139cp


    output of dmesg | grep eth0 is

    eth0: RealTek RTL8139 at 0xe0200000, 00:0f:b0:8e:d2:9a, IRQ 217
    eth0: Identified 8139 chip type 'RTL-8100B/8139D'
    eth0: link down
    ADDRCONF(NETDEV_UP): eth0: link is not ready


    The problem is that there is no activity in LAN card. The lights are not blinking, I cant ping any IP except the systems own IP (192.168.1.12) or the loopback IP.
    The ethtool eth0 command is also showing "link detected: no"
    I have checked the wire on other linux/windows PC's and it is working fine on other systems.

    Please help me to find and resolve the problem for which i'll be very thankful to you.

    Regards

  2. #2
    Just Joined!
    Join Date
    Oct 2010
    Location
    Reston, VA
    Posts
    26
    Looks like the module is not working properly. You could try the other module "8139cp"

    Sometimes you need to specify options to get it to work properly.

    Google "8139too options"

    You may need to specify the speed and or duplex to get it to work.

    -Gooney0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •