Find the answer to your Linux question:
Results 1 to 3 of 3
Hi all, I have two systems in my lab setup, each has two NIC cards. Take a look at the follwoing configuration that I have made, where eth0's of both ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2009
    Posts
    85

    Unhappy NIC Bonding Issues


    Hi all,
    I have two systems in my lab setup, each has two NIC cards. Take a look at the follwoing configuration that I have made, where eth0's of both the systems are connected to one switch and eth1's are connected to another switch. and both switches are isolated.

    I have used the bonding method on System-A
    bond0 configuration on SystemA : (mode = 1)
    IPAddress : 192.168.24.103/255.255.255.0
    System - A System - B
    ------------------------ ---------------------------
    eth0 | | <------------------------>Switch1<------------------------>eth0(192.168.24.21/255.255.255.0)
    eth1 | |<------------------------>Switch2<------------------------->eth1(192.168.25.31/255.255.255.0)

    Now when I started pinging from SystemA to 192.168.24.21. I thought ping should be succesful but it failed. I used tcpdump on SystemA with eth0 interface and I couldnt find any packet going thru eth0 interface, when I used tcpdump on eth1 interface I could find that arp is going on eth1 interface.
    When I remove the cable from eth1 cable from Switch2 on SystemB. Ping is working bcoz SystemA is taking eth0 as interface for ping.
    Again I have connected back the cable ping is working fine
    Now what is the mistake that I have done in the bonding interface, as the ping is going thru the wrong interface.
    Please anyone help me.. Its a cricital one for my project..
    If you want I will give the details of the bonding configuration.
    Thanks in advance.

  2. #2
    Just Joined!
    Join Date
    Oct 2010
    Location
    Reston, VA
    Posts
    26
    Been a while but here is how i did this:

    eth0: -> switch port 1
    eth1: -> switch port 2

    Configure bond0

    The switch must also be configured. On Cisco's they called this "Port group" this feature required the "enterprise" software.

    As the switch sees it:

    bond0 has an ip address which should load balance and failover between two different MAC addresses. Naturally the switch needs to be wise to this so it can send packets bound for the bond0 IP to two different switch ports.

    Also I think i had to disable STP (spanning tree protocol)

    -Gooney0

  3. #3
    Just Joined!
    Join Date
    Oct 2009
    Posts
    85
    Quote Originally Posted by gooney0 View Post
    Been a while but here is how i did this:

    eth0: -> switch port 1
    eth1: -> switch port 2

    Configure bond0

    The switch must also be configured. On Cisco's they called this "Port group" this feature required the "enterprise" software.

    As the switch sees it:

    bond0 has an ip address which should load balance and failover between two different MAC addresses. Naturally the switch needs to be wise to this so it can send packets bound for the bond0 IP to two different switch ports.

    Also I think i had to disable STP (spanning tree protocol)

    -Gooney0
    Hi, thanx for the reply.
    I really dont understand y my bonding interface is selecting the wrong interface(eth1) but not eth0.
    I dont have that kind of switches in the network. Can you please tell me what kind of work around should I do to get this done..

    Thanks

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •