Find the answer to your Linux question:
Results 1 to 2 of 2
Here is my setup: 1 physical server with VMWare ESXi on it 2 Virtual servers on the ESXi Server 1 physical NIC to the box I have always been able ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! jdh239's Avatar
    Join Date
    Sep 2006
    Posts
    55

    Really strange network issue... please help (SOLVED)


    Here is my setup:
    1 physical server with VMWare ESXi on it
    2 Virtual servers on the ESXi Server
    1 physical NIC to the box

    I have always been able to get to serverA and serverB on my ESXi server; however, sometime today I started experiencing connectivity issues to serverB. I restarted the server and now I can't get to serverB at all; however, I can still get to the ESXi server and serverA on the ESXi server. Because of that, I know my physical routing is still fine.

    While I cannot get to serverB, everyone else in the world can (which I confirmed by VPNing into work and hitting the site, and I checked with a brother to see if he could hit it too, which he could).

    Well, that led me to believe that the problem is on serverB itself, such as a firewall setting or something. I disabled the firewall, flushed the iptables, made sure that the /etc/hosts.deny file didn't have an entry in it for my current IP address/network, and disabled xinetd. I still cannot get to this box at all (http, ssh, etc).

    Where else should I look? I can't think of anything else that may be blocking it. I don't have apparmor enabled (openSuSe server), and I just am at a loss as to where to look.

    Come to think of it, serverA can reach serverB, so it isn't a problem with my network, but just my physical IP. I disabled the firewall and xinetd and even rebooted the box with those off, and I am still having the issue.......

    Any help would be greatly appreciated.
    Last edited by jdh239; 01-06-2011 at 06:58 AM.

  2. #2
    Just Joined! jdh239's Avatar
    Join Date
    Sep 2006
    Posts
    55
    I figured it out. Really stupid mistake, but finally found it.

    I have 16 subnet from my ISP, and my netmask is 255.255.255.240. I had a mask of 255.255.255.248 set on my router (different router than where the servers are), and the serverB address doesn't fall in the 248 mask, just serverA does.

    Anyway, hope someone else finds this useful.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •